aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml16
1 files changed, 11 insertions, 5 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 1bb1634..54f342b 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -7,12 +7,12 @@ build-backend = "setuptools.build_meta"
[project]
name = "argaze"
authors = [
- {name = 'ACHIL laboratory at Ecole Nationale de l\'Aviation Civile (ENAC)', email = 'achil@recherche.enac.fr'}
+ {
+ name = 'ACHIL laboratory at Ecole Nationale de l\'Aviation Civile (ENAC)',
+ email = 'argaze-contact@recherche.enac.fr'
+ }
]
-urls=[
- 'https://git.recherche.enac.fr/projects/argaze/'
-]
-description = "Open and Flexible Software Library for Gaze Analysis and Interaction."
+description = "An Open and Flexible Software Library for Gaze Analysis and Interaction."
readme= "README.md"
requires-python = ">=3.11"
keywords=[
@@ -46,5 +46,11 @@ dependencies = [
]
dynamic = ["version"]
+[project.urls]
+Homepage = "https://gitpub.recherche.enac.fr/argaze"
+Documentation = "http://achil.recherche.enac.fr/features/eye/argaze/index.html"
+Repository = "https://gitpub.recherche.enac.fr/argaze"
+Issues = "https://git.recherche.enac.fr/projects/argaze/issues"
+
[project.scripts]
demo="argaze ./src/argaze/utils/demo/ opencv_window_context_setup.json" \ No newline at end of file