summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorfourdan2006-05-24 14:45:31 +0000
committerfourdan2006-05-24 14:45:31 +0000
commiteeb65f8cd239e5a3367be902375c149ad7ac0f1b (patch)
treedf5fc49dc81555b3c4215b4b945786cee6fef2d1
parentfb3af665bef25a9056535b8ec2b90f109ee6908c (diff)
downloadivy-cplusplus-eeb65f8cd239e5a3367be902375c149ad7ac0f1b.zip
ivy-cplusplus-eeb65f8cd239e5a3367be902375c149ad7ac0f1b.tar.gz
ivy-cplusplus-eeb65f8cd239e5a3367be902375c149ad7ac0f1b.tar.bz2
ivy-cplusplus-eeb65f8cd239e5a3367be902375c149ad7ac0f1b.tar.xz
Fix make install if dest dirs are missing, add Debian administrative files, so first Debian package of ivy-cpp is now ready ;)
-rw-r--r--Ivy.d1
-rw-r--r--IvyApplication.d2
-rw-r--r--Ivy_glfw.d3
-rw-r--r--Makefile4
-rw-r--r--debian/README0
-rw-r--r--debian/changelog7
-rw-r--r--debian/compat1
-rw-r--r--debian/control36
-rw-r--r--debian/dirs2
-rw-r--r--debian/ivy-cpp-dev.dirs2
-rw-r--r--debian/ivy-cpp-dev.install2
-rw-r--r--debian/ivy-cpp-glfw.dirs1
-rw-r--r--debian/ivy-cpp-glfw.install1
-rw-r--r--debian/ivy-cpp.dirs1
-rw-r--r--debian/ivy-cpp.install1
-rwxr-xr-xdebian/rules65
-rw-r--r--debian/substvars1
17 files changed, 124 insertions, 6 deletions
diff --git a/Ivy.d b/Ivy.d
deleted file mode 100644
index bd1c1a8..0000000
--- a/Ivy.d
+++ /dev/null
@@ -1 +0,0 @@
-Ivy.o: Ivy.cxx Ivycpp.h IvyCallback.h IvyApplication.h
diff --git a/IvyApplication.d b/IvyApplication.d
deleted file mode 100644
index aaecda3..0000000
--- a/IvyApplication.d
+++ /dev/null
@@ -1,2 +0,0 @@
-IvyApplication.o: IvyApplication.cxx IvyApplication.h Ivycpp.h \
- IvyCallback.h
diff --git a/Ivy_glfw.d b/Ivy_glfw.d
deleted file mode 100644
index b828482..0000000
--- a/Ivy_glfw.d
+++ /dev/null
@@ -1,3 +0,0 @@
-Ivy_glfw.o: Ivy_glfw.cxx Ivy.cxx Ivycpp.h /usr/X11R6/include/GL/glfw.h \
- /usr/X11R6/include/GL/gl.h /usr/X11R6/include/GL/glext.h \
- /usr/X11R6/include/GL/glu.h IvyCallback.h IvyApplication.h
diff --git a/Makefile b/Makefile
index 6696bf7..bdf0f9c 100644
--- a/Makefile
+++ b/Makefile
@@ -1,4 +1,6 @@
+
# $Id$
+
os=$(shell uname -s)
ifeq ($(os),Darwin)
@@ -79,8 +81,10 @@ $(LIBIVY_GLFW_SHARED) : $(OBJECTS_GLFW)
install:
# headers
+ mkdir -p $(DESTDIR)$(PREFIX)/include/Ivy
install -m 0644 Ivy*.h $(DESTDIR)$(PREFIX)/include/Ivy
# libs
+ mkdir -p $(DESTDIR)$(PREFIX)/lib
install -m 0644 $(LIBIVY_STATIC) $(DESTDIR)$(PREFIX)/lib
install -m 0644 $(LIBIVY_GLFW_STATIC) $(DESTDIR)$(PREFIX)/lib
install -m 0644 $(LIBIVY_SHARED) $(DESTDIR)$(PREFIX)/lib
diff --git a/debian/README b/debian/README
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/debian/README
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..efadb73
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,7 @@
+ivy-cpp (1.0-1) unstable; urgency=low
+
+ * Initial Release.
+
+ -- Olivier Fourdan <fourdan@cena.fr> Wed, 24 May 2006 16:25:02 +0200
+
+
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..b8626c4
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+4
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..944be4f
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,36 @@
+Source: ivy-cpp
+Priority: extra
+Section: devel
+Maintainer: Alexandre Bustico <alexandre.bustico@cena.fr>
+Build-Depends: debhelper (>> 4.0.0)
+Standards-Version: 3.6.1
+
+Package: ivy-cpp-dev
+Section: libdevel
+Architecture: any
+Depends: ivy-cpp (= ${Source-Version}), ivy-cpp-glfw (= ${Source-Version}), libc6-dev, xlibs-dev
+Description: C++ api for Ivy software bus. development Package
+ This package is needed for compiling applications using ivy in C++.
+ Ivy is mostly a communication convention between processes, implemented
+ through a collection of libraries in several languages and for several platforms,
+ from C to Perl, from Macintosh or WindowsNT to Linux or Unix.
+
+Package: ivy-cpp
+Section: libs
+Architecture: any
+Depends: ${shlibs:Depends}, ivy-c (>= 3.8), libpcre3, libpthread0, xlibmesa-gl, libxxf86vm1
+Build-Depends: debhelper, libc6-dev, xlibs-dev, ivy-c-dev (>= 3.8), xlibmesa-gl-dev, libpcre3-dev
+Description: C++ api for Ivy software bus. runtime Package
+ Ivy is mostly a communication convention between processes, implemented
+ through a collection of libraries in several languages and for several platforms:
+ from C to Perl, from Macintosh or WindowsNT to Linux or Unix.
+
+Package: ivy-cpp-glfw
+Section: libs
+Architecture: any
+Depends: ${shlibs:Depends}, ivy-c (>= 3.8), libpcre3, libpthread0, xlibmesa-gl, libxxf86vm1, glfw
+Build-Depends: debhelper, libc6-dev, xlibs-dev, ivy-c-dev (>= 3.8), xlibmesa-gl-dev, libpcre3-dev
+Description: C++ api for Ivy software bus. runtime Package
+ Ivy is mostly a communication convention between processes, implemented
+ through a collection of libraries in several languages and for several platforms:
+ from C to Perl, from Macintosh or WindowsNT to Linux or Unix.
diff --git a/debian/dirs b/debian/dirs
new file mode 100644
index 0000000..048640b
--- /dev/null
+++ b/debian/dirs
@@ -0,0 +1,2 @@
+usr/lib
+usr/include/Ivy
diff --git a/debian/ivy-cpp-dev.dirs b/debian/ivy-cpp-dev.dirs
new file mode 100644
index 0000000..048640b
--- /dev/null
+++ b/debian/ivy-cpp-dev.dirs
@@ -0,0 +1,2 @@
+usr/lib
+usr/include/Ivy
diff --git a/debian/ivy-cpp-dev.install b/debian/ivy-cpp-dev.install
new file mode 100644
index 0000000..3d05149
--- /dev/null
+++ b/debian/ivy-cpp-dev.install
@@ -0,0 +1,2 @@
+usr/lib/*.a
+usr/include/Ivy/*.h
diff --git a/debian/ivy-cpp-glfw.dirs b/debian/ivy-cpp-glfw.dirs
new file mode 100644
index 0000000..6845771
--- /dev/null
+++ b/debian/ivy-cpp-glfw.dirs
@@ -0,0 +1 @@
+usr/lib
diff --git a/debian/ivy-cpp-glfw.install b/debian/ivy-cpp-glfw.install
new file mode 100644
index 0000000..5c943ec
--- /dev/null
+++ b/debian/ivy-cpp-glfw.install
@@ -0,0 +1 @@
+usr/lib/libIvy_glfw.so
diff --git a/debian/ivy-cpp.dirs b/debian/ivy-cpp.dirs
new file mode 100644
index 0000000..6845771
--- /dev/null
+++ b/debian/ivy-cpp.dirs
@@ -0,0 +1 @@
+usr/lib
diff --git a/debian/ivy-cpp.install b/debian/ivy-cpp.install
new file mode 100644
index 0000000..a763390
--- /dev/null
+++ b/debian/ivy-cpp.install
@@ -0,0 +1 @@
+usr/lib/libIvy.so
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..41fccae
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,65 @@
+#!/usr/bin/make -f
+# Made with the aid of debmake, by Christoph Lameter,
+# based on the sample debian/rules file for GNU hello by Ian Jackson.
+
+# Uncomment this to turn on verbose mode.
+export DH_VERBOSE=1
+
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+ touch configure-stamp
+
+build: build-stamp
+build-stamp: configure-stamp
+ dh_testdir
+ $(MAKE)
+ touch build-stamp
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+ $(MAKE) clean
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+ $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
+
+binary-indep: build install
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_installexamples
+ dh_install --source=$(CURDIR)/debian/tmp
+# dh_installmenu
+# dh_installdebconf
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+# dh_installinit
+# dh_installcron
+# dh_installinfo
+ dh_installman
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+# dh_perl
+# dh_python
+# dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure
diff --git a/debian/substvars b/debian/substvars
new file mode 100644
index 0000000..dc83102
--- /dev/null
+++ b/debian/substvars
@@ -0,0 +1 @@
+shlibs:Depends=libc6 (>= 2.3.2.ds1-21), libglib2.0-0 (>= 2.6.0), libice6, libpcre3 (>= 4.5), libsm6, libx11-6, libxt6