summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormertz2003-09-17 16:18:24 +0000
committermertz2003-09-17 16:18:24 +0000
commitea6ff5095dd6bd743b39abd26f2ecb8dd4dd5382 (patch)
tree685b99775b1aa4a9e5cf6c68c3b1e247cf9e68f5
parent0730268d1ec53cccaf79ae58426ff097f48f553c (diff)
downloadivy-perl-ea6ff5095dd6bd743b39abd26f2ecb8dd4dd5382.zip
ivy-perl-ea6ff5095dd6bd743b39abd26f2ecb8dd4dd5382.tar.gz
ivy-perl-ea6ff5095dd6bd743b39abd26f2ecb8dd4dd5382.tar.bz2
ivy-perl-ea6ff5095dd6bd743b39abd26f2ecb8dd4dd5382.tar.xz
the old, specific CENA perl module gettimeofday-perl has been replaced by
the CPAN world-wide used Time::HiRes module
-rw-r--r--Ivy.pm12
-rw-r--r--Makefile.PL2
-rw-r--r--debian/changelog7
-rw-r--r--debian/control2
4 files changed, 15 insertions, 8 deletions
diff --git a/Ivy.pm b/Ivy.pm
index 223b064..06edc17 100644
--- a/Ivy.pm
+++ b/Ivy.pm
@@ -1,7 +1,7 @@
#
# Ivy, Perl interface
#
-# Copyright 1997-2002
+# Copyright 1997-2003
# Centre d'Études de la Navigation Aérienne
#
# Authors: Alexandre Bustico <bustico@cena.fr>
@@ -35,7 +35,7 @@ package Ivy ;
use Sys::Hostname;
use IO::Socket;
use strict;
-use Time::Gettimeofday;
+use Time::HiRes qw(gettimeofday);
use Carp;
use IO::Socket::Multicast;
@@ -943,7 +943,7 @@ sub after ($$;$)
# si la valeur de timout est negative : c'est un after sinon
# c'est un repeat
$afterList{++$afterId} = [AFTER, $timeAfter,
- timeofday()+$timeAfter, $cbListRef];
+ gettimeofday()+$timeAfter, $cbListRef];
return ($afterId);
} # end after
@@ -961,7 +961,7 @@ sub repeat ($$;$)
$timeAfter /= 1000;
$selectTimout = $timeAfter if $timeAfter < $selectTimout;
- $afterList{++$afterId}= [REPEAT, $timeAfter, timeofday()+$timeAfter,
+ $afterList{++$afterId}= [REPEAT, $timeAfter, gettimeofday()+$timeAfter,
$cbListRef];
return ($afterId);
} # end repeat
@@ -1005,7 +1005,7 @@ sub afterResetTimer ($;$)
my $id = shift;
if (defined ($id) && defined $afterList{$id}) {
- $afterList{$id}->[2] = $afterList{$id}->[1] + timeofday();
+ $afterList{$id}->[2] = $afterList{$id}->[1] + gettimeofday();
}
} # end afterResetTimer
@@ -1547,7 +1547,7 @@ sub _tkFileEvent ($$)
############### PROCEDURE SCAN AFTER
sub _scanAfter ()
{
- my $stamp = timeofday ();
+ my $stamp = gettimeofday ();
$selectTimout = MAX_TIMOUT;
foreach my $afk (keys %afterList) {
my $af = $afterList{$afk};
diff --git a/Makefile.PL b/Makefile.PL
index 4a511e9..8535c74 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -5,7 +5,7 @@ WriteMakefile(
'NAME' => 'Ivy',
'VERSION_FROM' => 'Ivy.pm', # finds $VERSION
'PREREQ_PM' => {
- 'Time::Gettimeofday' => 0.02,
+ 'Time::HiRes' => 1.17,
'IO::Socket::Multicast' => 0.25,
},
'PM' => {'Ivy.pm' => '$(INST_LIBDIR)/Ivy.pm'},
diff --git a/debian/changelog b/debian/changelog
index f4ccb48..eb7f75c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+ivy-perl (4.16) unstable; urgency=low
+
+ * ivy now uses libtime-hires-perl, a standard debian package rather
+ than our previous specific gettimeofday-perl
+
+ -- Christophe Mertz <mertz@tls.cena.fr> Mon, 15 Sep 2003 11:05:32 +0200
+
ivy-perl (4.15) unstable; urgency=low
* Fixed problem with multiple addresses in gethostbyname(hostname())
diff --git a/debian/control b/debian/control
index 4f162bb..6365be6 100644
--- a/debian/control
+++ b/debian/control
@@ -6,7 +6,7 @@ Standards-Version: 3.5.6.0
Package: ivy-perl
Architecture: all
-Depends: ${perl:Depends}, perl-tk, gettimeofday-perl (>= 1.0.1), libsocket-multicast-perl (>= 0.25)
+Depends: ${perl:Depends}, perl-tk, libtime-hires-perl (>= 1.20-4), libsocket-multicast-perl (>= 0.25)
Build-Depends: debhelper (>= 3.0.18)
Description: Perl module and documentation for using the Ivy software bus
Ivy is mostly a communication convention between processes, implemented