summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules62
1 files changed, 62 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..0204846
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,62 @@
+#!/usr/bin/make -f
+# Made with the aid of debmake, by Christoph Lameter,
+# based on the sample debian/rules file for GNU hello by Ian Jackson.
+
+package=ivycontrolpanel
+
+build:
+ $(checkdir)
+ pod2man src/$(package) > doc/$(package).1
+ touch build
+
+clean:
+ $(checkdir)
+ -rm -f build
+ -rm -f `find . -name "*~"`
+ -rm -rf debian/tmp debian/files* core debian/substvars
+
+binary-indep: checkroot build
+ $(checkdir)
+ -rm -rf debian/tmp
+ install -d debian/tmp/usr/bin
+ install -d debian/tmp/usr/
+ install -d debian/tmp/usr/lib/$(package)
+ install -d debian/tmp/usr/share/$(package)
+ install -d debian/tmp/usr/share/man/man1
+
+ pod2man src/$(package) > debian/tmp/usr/share/man/man1/$(package).1
+ install -m755 src/ivycontrolpanel debian/tmp/usr/bin/$(package)
+ for f in src/*.pm; do \
+ install -m644 $$f debian/tmp/usr/lib/$(package); \
+ done
+ for f in images/*; do \
+ install -m644 $$f debian/tmp/usr/share/$(package); \
+ done
+# Must have debmake installed for this to work. Otherwise please copy
+# /usr/bin/debstd into the debian directory and change debstd to debian/debstd
+ debstd debian/copyright debian/changelog doc/*.1 doc/ivycontrolpanel.gif
+ dpkg-gencontrol -isp
+ chown -R root.root debian/tmp
+ chmod -R go=rX debian/tmp
+ dpkg --build debian/tmp ..
+
+binary-arch: checkroot build
+ $(checkdir)
+# There are no architecture-independent files to be uploaded
+# generated by this package. If there were any they would be
+# made here.
+
+define checkdir
+ test -f debian/rules
+endef
+
+# Below here is fairly generic really
+
+binary: binary-indep binary-arch
+
+checkroot:
+ $(checkdir)
+ test root = "`whoami`"
+
+.PHONY: binary binary-arch binary-indep clean checkroot
+