summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog9
-rw-r--r--debian/control11
-rw-r--r--debian/copyright4
-rw-r--r--debian/dirs2
-rw-r--r--debian/files1
-rwxr-xr-xdebian/rules48
6 files changed, 75 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..f6cebf4
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,9 @@
+ivymon (0.1) unstable; urgency=low
+
+ * Initial release.
+
+ -- Daniel ETIENNE <etienne@cena.dgac.fr> Wed, 27 Dec 2000 14:15:05 +0100
+
+Local variables:
+mode: debian-changelog
+End:
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..2ea993a
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,11 @@
+Source: ivymon
+Section: unknown
+Priority: optional
+Maintainer: Daniel ETIENNE <etienne@cena.dgac.fr>
+Standards-Version: 3.1.1
+
+Package: ivymon
+Architecture: any
+Depends: perl-tk, ivy-perl (>=4.3)
+Description: IvyMon, a graphical application for monitoring Ivy
+ IvyMon, a graphical application for monitoring Ivy
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..507e5a6
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,4 @@
+This package was written by Daniel ETIENNE etienne@cena.dgac.fr on Wed, 27 Dec 2000 14:15:05 +0100.
+
+Copyright: GPL (see /usr/share/common-licenses/GPL)
+
diff --git a/debian/dirs b/debian/dirs
new file mode 100644
index 0000000..ca882bb
--- /dev/null
+++ b/debian/dirs
@@ -0,0 +1,2 @@
+usr/bin
+usr/sbin
diff --git a/debian/files b/debian/files
new file mode 100644
index 0000000..410773c
--- /dev/null
+++ b/debian/files
@@ -0,0 +1 @@
+ivymon_0.1_i386.deb unknown optional
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..60ecf04
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,48 @@
+#!/usr/bin/make -f
+# Made with the aid of debmake, by Christoph Lameter,
+# based on the sample debian/rules file for GNU hello by Ian Jackson.
+
+package=ivymon
+
+build:
+ $(checkdir)
+ touch build
+
+clean:
+ $(checkdir)
+ -rm -f build
+ -$(MAKE) clean
+ -rm -f `find . -name "*~"`
+ -rm -rf debian/tmp debian/files* core debian/substvars
+
+binary-indep: checkroot build
+ $(checkdir)
+# There are no architecture-independent files to be uploaded
+# generated by this package. If there were any they would be
+# made here.
+
+binary-arch: checkroot build
+ $(checkdir)
+ -rm -rf debian/tmp
+ install -d debian/tmp
+ cd debian/tmp && install -d `cat ../dirs`
+ install -m755 src/ivymon debian/tmp/usr/bin/ivymon
+# Must have debmake installed for this to work. Otherwise please copy
+# /usr/bin/debstd into the debian directory and change debstd to debian/debstd
+ debstd
+ dpkg-gencontrol
+ chown -R root.root debian/tmp
+ chmod -R go=rX debian/tmp
+ dpkg --build debian/tmp ..
+
+define checkdir
+ test -f debian/rules
+endef
+
+binary: binary-indep binary-arch
+
+checkroot:
+ $(checkdir)
+ test root = "`whoami`"
+
+.PHONY: binary binary-arch binary-indep clean checkroot