aboutsummaryrefslogtreecommitdiff
path: root/Perl/Makefile.PL
diff options
context:
space:
mode:
authorlecoanet1999-12-09 13:17:54 +0000
committerlecoanet1999-12-09 13:17:54 +0000
commit31e7a4237120f49830c2b1ae751dda825570a0fd (patch)
tree340a586a029630ba76863c82bd44e98061aa147b /Perl/Makefile.PL
parentdd871f7fd7028172b5fe86e322b0cc54a24c9e92 (diff)
downloadtkzinc-31e7a4237120f49830c2b1ae751dda825570a0fd.zip
tkzinc-31e7a4237120f49830c2b1ae751dda825570a0fd.tar.gz
tkzinc-31e7a4237120f49830c2b1ae751dda825570a0fd.tar.bz2
tkzinc-31e7a4237120f49830c2b1ae751dda825570a0fd.tar.xz
Param�trage pour g�n�rer une bib debug.
Diffstat (limited to 'Perl/Makefile.PL')
-rw-r--r--Perl/Makefile.PL9
1 files changed, 5 insertions, 4 deletions
diff --git a/Perl/Makefile.PL b/Perl/Makefile.PL
index c453a5b..a366b55 100644
--- a/Perl/Makefile.PL
+++ b/Perl/Makefile.PL
@@ -1,16 +1,17 @@
-
+#
+# The first argument should be the name of the radar library
+# either ptkradar or ptkradr_debug for example.
+#
use Tk::MMutil;
use Tk::Config;
Tk::MMutil::TkExtMakefile(
'NAME' => 'Tk::Radar',
'OBJECT' => '$(O_FILES)',
- 'MYEXTLIB' => '../libptkradar.a',
'VERSION_FROM' => 'Radar.pm',
'XS_VERSION' => $Tk::Config::VERSION,
'INC' => "-I. -I/usr/lib/perl5/i386-linux/5.004/Tk/pTk",
- 'LIBS' => '-L/usr/X11R6/lib -lX11'
-);
+ 'LIBS' => "-L/usr/X11R6/lib -L.. -l$ARGV[0] -lX11");