aboutsummaryrefslogtreecommitdiff
path: root/Perl/Makefile.PL
diff options
context:
space:
mode:
authormertz2004-03-06 15:42:53 +0000
committermertz2004-03-06 15:42:53 +0000
commit7cf0eb9b7d071512622e3a33675565dd8f471d59 (patch)
tree9340826ed36eb4a27db756ff1838e778775f776e /Perl/Makefile.PL
parenta9cede170f4d90eee8789ddf8c94585d7fde0062 (diff)
downloadtkzinc-7cf0eb9b7d071512622e3a33675565dd8f471d59.zip
tkzinc-7cf0eb9b7d071512622e3a33675565dd8f471d59.tar.gz
tkzinc-7cf0eb9b7d071512622e3a33675565dd8f471d59.tar.bz2
tkzinc-7cf0eb9b7d071512622e3a33675565dd8f471d59.tar.xz
the PTK800 flag is set according to Tk::$VERSION rather than set
explicitely in the script
Diffstat (limited to 'Perl/Makefile.PL')
-rw-r--r--Perl/Makefile.PL9
1 files changed, 7 insertions, 2 deletions
diff --git a/Perl/Makefile.PL b/Perl/Makefile.PL
index bf76ab5..150a32e 100644
--- a/Perl/Makefile.PL
+++ b/Perl/Makefile.PL
@@ -100,8 +100,7 @@ sub get_flags {
if ($WIN) {
$DEF_FLAGS{'SHAPE'} = 0;
}
-# my $defines = '-DPTK';
- my $defines = '-DPTK -DPTK_800';
+ my $defines = '-DPTK';
print "Configuring with:\n ";
foreach my $flag (keys %DEF_FLAGS) {
print "$flag=", $DEF_FLAGS{$flag} ? 'ok' : 'no', " ";
@@ -112,6 +111,12 @@ sub get_flags {
}
}
}
+ if ($Tk::VERSION =~ /^800/) {
+ $defines .= " -DPTK_800";
+ print "PTK=800";
+ } else {
+ print "PTK=804";
+ }
print "\n";
return $defines;
}