aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorlecoanet2003-03-17 15:55:10 +0000
committerlecoanet2003-03-17 15:55:10 +0000
commitcd737c714e95be2424367ee880d5a765f7cea1db (patch)
treee3c6b9f65e0d4c31d38a5bca53813c355b858870 /debian/rules
parent8659aa58f45c81a2554ab39c5f9384d6d0295022 (diff)
downloadtkzinc-cd737c714e95be2424367ee880d5a765f7cea1db.zip
tkzinc-cd737c714e95be2424367ee880d5a765f7cea1db.tar.gz
tkzinc-cd737c714e95be2424367ee880d5a765f7cea1db.tar.bz2
tkzinc-cd737c714e95be2424367ee880d5a765f7cea1db.tar.xz
* Ajout de code pour l'instalation du package Python
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules27
1 files changed, 17 insertions, 10 deletions
diff --git a/debian/rules b/debian/rules
index 6f483f2..9c55224 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,6 +8,9 @@ version_major=$(shell expr `pwd` : '.*-\([0-9]*\).[0-9.]*')
INSTALLARCHLIB=`perl -MConfig -e 'print $$Config{installarchlib}'`
INSTALL_PERL=pure_install PREFIX=`pwd`/debian/tmp/usr
+DEFAULT_VERSION_PYTHON=$(shell echo `dpkg -p python| grep -e "^Version:" |cut -d" " -f2|cut -d"." -f1-2` )
+ZINCPYTHON := $(shell pwd)/debian/zinc-python
+
TMP=`pwd`/debian/tmp
@@ -34,15 +37,14 @@ clean:
-rm -f debian/*substvars
binary-indep: checkroot build
$(checkdir)
-# There are no architecture-independent files to be uploaded
-# generated by this package. If there were any they would be
-# made here.
+ $(MAKE) -f Makefile python
binary-arch: checkroot build
$(checkdir)
install -d debian/tmp
cd debian/tmp && install -d `cat ../dirs`
+ grep -q "usr/lib/python$(DEFAULT_VERSION_PYTHON)/site-packages" debian/dirs || echo "usr/lib/python$(DEFAULT_VERSION_PYTHON)/site-packages" >> debian/dirs
$(MAKE) install prefix=`pwd`/debian/tmp/usr INSTALL_PERL=$(INSTALL_PERL)
-install -m644 doc/refman/*.html doc/refman/refman.css doc/refman/*.png debian/tmp/usr/share/doc/zinc-tk/refman
@@ -56,25 +58,30 @@ binary-arch: checkroot build
find debian/tmp/usr/lib/perl -type f -name .packlist | xargs rm -f
find debian/tmp/usr/lib/perl5 -type f -name .packlist | xargs rm -f
-# install -m644 Python/Zinc.py debian/tmp/usr/lib/python1.5/site-packages/
-# install -m644 debian/copyright debian/tmp/usr/share/doc/zinc-python
-# install -m644 debian/changelog debian/tmp/usr/share/doc/zinc-python
-# gzip -9 debian/tmp/usr/share/doc/zinc-python/changelog
+ install -m644 Python/Zinc.py debian/tmp/usr/lib/python$(DEFAULT_VERSION_PYTHON)/site-packages/
+ install -m644 debian/copyright debian/tmp/usr/share/doc/zinc-python
+ install -m644 debian/changelog debian/tmp/usr/share/doc/zinc-python
+ gzip -9 debian/tmp/usr/share/doc/zinc-python/changelog
+ echo -e "usr/share/doc/zinc-python\nusr/lib/python$(DEFAULT_VERSION_PYTHON)" > debian/zinc-python.files
# strip --strip-unneeded debian/tmp/usr/lib/tkzinc3.1.so
# strip --strip-unneeded debian/tmp/usr/lib/libom.so
# strip --strip-unneeded debian/tmp/usr/lib/libgpc.so
# strip --strip-unneeded debian/tmp/usr/lib/libptkzinc3.1.so
- debstd -m -c -s INSTALL BUGS doc/refman.pdf
+ debstd -m -c -s BUGS doc/refman.pdf
dh_md5sums
-rm -Rf debian/tmp/usr/share/doc/zinc-perl debian/tmp/usr/lib/perl5
-rm -Rf debian/tmp/usr/lib/perl debian/tmp/usr/share/perl
-# -rm -Rf debian/tmp/usr/share/doc/zinc-python debian/tmp/usr/lib/python1.5
- dpkg-gencontrol -isp -pzinc-tk
+ -rm -Rf debian/tmp/usr/share/doc/zinc-python debian/tmp/usr/lib/python$(DEFAULT_VERSION_PYTHON)
+ dpkg-gencontrol -VPythonVersion=$(DEFAULT_VERSION_PYTHON) -isp -pzinc-tk
chown -R root.root debian/tmp
chmod -R go=rX debian/tmp
dpkg --build debian/tmp ..
+ -rm -f debian/zinc-python.files
+ mv debian/dirs debian/.dirs.tmp
+ grep -v "usr/lib/python$(DEFAULT_VERSION_PYTHON)/site-packages" debian/.dirs.tmp >| debian/dirs
+ rm -f debian/.dirs.tmp
define checkdir
test -f debian/rules