aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorlecoanet1999-12-09 14:11:11 +0000
committerlecoanet1999-12-09 14:11:11 +0000
commitb1f79aa9ff6b5d7a66d91905e5c63549b9e2cc09 (patch)
tree57047e01cd85f454a7962352de5aadf9db0c5060 /debian/rules
parent31e7a4237120f49830c2b1ae751dda825570a0fd (diff)
downloadtkzinc-b1f79aa9ff6b5d7a66d91905e5c63549b9e2cc09.zip
tkzinc-b1f79aa9ff6b5d7a66d91905e5c63549b9e2cc09.tar.gz
tkzinc-b1f79aa9ff6b5d7a66d91905e5c63549b9e2cc09.tar.bz2
tkzinc-b1f79aa9ff6b5d7a66d91905e5c63549b9e2cc09.tar.xz
Ajustement des targets de compilation.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules68
1 files changed, 68 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..5ab6bd4
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,68 @@
+#!/usr/bin/make -f
+# Made with the aid of debmake, by Christoph Lameter,
+# based on the sample debian/rules file for GNU hello by Ian Jackson.
+
+version=$(shell expr `pwd` : '.*-\([0-9.]*\)')
+version_major=$(shell expr `pwd` : '.*-\([0-9]*\).[0-9.]*')
+
+build:
+ $(checkdir)
+
+ ./configure --prefix=/usr/X11R6
+
+#
+# Build the static library (it does not need Position Independent Code,
+# which reserves one register; thus, without -fPIC we get more efficient
+# code).
+#
+ $(MAKE) -f Makefile tkradar ptkradar doc
+ touch build
+
+clean:
+ $(checkdir)
+ -rm -f build
+ -rm -f config.cache
+ -make distclean
+ -rm -f `find . -name "*~"`
+ -rm -rf debian/tmp `find debian/* -type d ! -name CVS` debian/files* core
+ -rm -f debian/*substvars
+binary-indep: checkroot build
+ $(checkdir)
+# There are no architecture-independent files to be uploaded
+# generated by this package. If there were any they would be
+# made here.
+
+binary-arch: checkroot build
+ $(checkdir)
+ install -d debian/tmp
+ cd debian/tmp && install -d `cat ../dirs`
+
+ $(SHELL) -c ". /root/.bashrc; $(MAKE) install prefix=`pwd`/debian/tmp/usr"
+
+ -rm -f debian/tmp/usr/lib/perl5/i386-linux/5.004/perllocal.pod
+
+ install -m644 Perl/t/radar.pl debian/tmp/usr/doc/xradar3-perl/examples
+ install -m644 test/*.tcl test/*.pl debian/tmp/usr/doc/xradar3-tk/examples
+
+ install -m644 Python/Radar.py debian/tmp/usr/lib/python1.5/site-packages/
+
+ debstd -m ChangeLog muwr.tex refman.tex refman.ps
+ -rm -Rf debian/tmp/usr/doc/xradar3-perl debian/tmp/usr/lib/perl5
+ dpkg-gencontrol -pxradar3-tk
+ chown -R root.root debian/tmp
+ chmod -R go=rX debian/tmp
+ dpkg --build debian/tmp ..
+
+define checkdir
+ test -f debian/rules
+endef
+
+# Below here is fairly generic really
+
+binary: binary-indep binary-arch
+
+checkroot:
+ $(checkdir)
+ test root = "`whoami`"
+
+.PHONY: binary binary-arch binary-indep clean checkroot