aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorlecoanet2000-02-04 15:05:00 +0000
committerlecoanet2000-02-04 15:05:00 +0000
commit3f47be9fe5d3006927c79eb156cfbed946243e26 (patch)
tree290e6129a217eb3696b193f15fd7f2cdbb6d1e83 /debian
parent64089dca388f5a9a8235a94b4372763875132219 (diff)
downloadtkzinc-3f47be9fe5d3006927c79eb156cfbed946243e26.zip
tkzinc-3f47be9fe5d3006927c79eb156cfbed946243e26.tar.gz
tkzinc-3f47be9fe5d3006927c79eb156cfbed946243e26.tar.bz2
tkzinc-3f47be9fe5d3006927c79eb156cfbed946243e26.tar.xz
Ameliorations de la compil/installation en Perl
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog7
-rwxr-xr-xdebian/rules13
2 files changed, 15 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index 3f114ba..3e8572b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+zinc-tk (3.1.10) unstable; urgency=low
+
+ * Modifications pour une meilleure configuration de la compil
+ et du test en Perl.
+
+ -- Patrick Lecoanet <lecoanet@cena.dgac.fr> Fri, 4 Feb 2000 15:42:11 +0100
+
zinc-tk (3.1.9) unstable; urgency=low
* Passage du nom radar au nom zinc.
diff --git a/debian/rules b/debian/rules
index 80451a2..e5b09dd 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,6 +5,11 @@
version=$(shell expr `pwd` : '.*-\([0-9.]*\)')
version_major=$(shell expr `pwd` : '.*-\([0-9]*\).[0-9.]*')
+INSTALLARCHLIB=`perl -MConfig -e 'print $$Config{installarchlib}'`
+
+TMP=`pwd`/debian/tmp
+
+
build:
$(checkdir)
@@ -15,7 +20,7 @@ build:
# which reserves one register; thus, without -fPIC we get more efficient
# code).
#
- $(MAKE) -f Makefile tkzinc ptkzinc doc
+ $(MAKE) -f Makefile INSTALLMAN1DIR=$(TMP)/usr/man/man1 INSTALLMAN3DIR=$(TMP)/usr/man/man3 INSTALLPRIVLIB=$(TMP)/usr/lib/perl5 INSTALLARCHLIB=$(TMP)$(INSTALLARCHLIB) tkzinc ptkzinc doc
touch build
clean:
@@ -37,11 +42,9 @@ binary-arch: checkroot build
install -d debian/tmp
cd debian/tmp && install -d `cat ../dirs`
- $(SHELL) -c ". /root/.bashrc; $(MAKE) install prefix=`pwd`/debian/tmp/usr"
-
- -rm -f debian/tmp/usr/lib/perl5/i386-linux/5.004/perllocal.pod
+ $(MAKE) install prefix=`pwd`/debian/tmp/usr INSTALL_PERL=pure_install
- install -m644 Perl/t/zinc.pl debian/tmp/usr/doc/zinc-perl/examples
+ install -m644 Perl/t/zinc.t debian/tmp/usr/doc/zinc-perl/examples
install -m644 test/*.tcl test/*.pl debian/tmp/usr/doc/zinc-tk/examples
install -m644 Python/Zinc.py debian/tmp/usr/lib/python1.5/site-packages/