aboutsummaryrefslogtreecommitdiff
path: root/Perl/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Perl/Makefile.PL')
-rw-r--r--Perl/Makefile.PL18
1 files changed, 18 insertions, 0 deletions
diff --git a/Perl/Makefile.PL b/Perl/Makefile.PL
index d731648..ebcd5ec 100644
--- a/Perl/Makefile.PL
+++ b/Perl/Makefile.PL
@@ -53,6 +53,24 @@ unless ($WIN) {
$INC .= " -I/usr/X11R6/include";
}
+#For some reason which the author of ExtUtils::MM_Unix forget, Unix machines like to have
+#PERL_DL_NONLAZY set for tests. This is FALSE for TkZinc.
+
+sub ExtUtils::MM_Unix::test_via_harness {
+ my($self, $perl, $tests) = @_;
+# return $self->SUPER::test_via_harness("PERL_DL_NONLAZY=1 $perl", $tests);
+ # I should use the SUPER method, but this needs some import tunning...
+ return ExtUtils::MM_Any::test_via_harness($self, $perl, $tests);
+}
+
+#Again, the PERL_DL_NONLAZY thing.
+sub ExtUtils::MM_Unix::test_via_script {
+ my($self, $perl, $script) = @_;
+# return $self->SUPER::test_via_script("PERL_DL_NONLAZY=1 $perl", $script);
+ # I should use the SUPER method, but this needs some import tunning...
+ return ExtUtils::MM_Any::test_via_script($self, $perl, $script);
+}
+
# See lib/ExtUtils/MakeMaker.pm for details of how to influence
# the contents of the Makefile that is written.
WriteMakefile(