aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorThéo de la Hogue2024-04-08 21:06:40 +0200
committerThéo de la Hogue2024-04-08 21:06:40 +0200
commit007feec2a8d8de80f40b021710c6e6b382a0e886 (patch)
tree9963a1d9b240128e6a631cffbedf25529b1b49ff /pyproject.toml
parent3cc3dd1c3ba0f4010f45e68615b342127cba6f6e (diff)
downloadargaze-007feec2a8d8de80f40b021710c6e6b382a0e886.zip
argaze-007feec2a8d8de80f40b021710c6e6b382a0e886.tar.gz
argaze-007feec2a8d8de80f40b021710c6e6b382a0e886.tar.bz2
argaze-007feec2a8d8de80f40b021710c6e6b382a0e886.tar.xz
Fixing typo and docstrings.
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml49
1 files changed, 48 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index b0f0765..6690224 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,3 +1,50 @@
[build-system]
-requires = ["setuptools>=42"]
+requires = [
+ "setuptools",
+]
build-backend = "setuptools.build_meta"
+
+[project]
+name = "argaze"
+authors = [
+ {name = 'ACHIL laboratory at Ecole Nationale de l\'Aviation Civile (ENAC)', email = 'achil@recherche.enac.fr'}
+]
+urls=[
+ 'https://git.recherche.enac.fr/projects/argaze/'
+]
+description = "A modular real-time and post-processing gaze analysis software library."
+readme= "README.md"
+requires-python = ">=3.11"
+keywords=[
+ "eye tracking",
+ "gaze analysis",
+ "real-time",
+ "modular"
+]
+license = {text = "GPLv3"}
+classifiers=[
+ 'Development Status :: 3 - Alpha',
+ 'Intended Audience :: Developers',
+ 'Intended Audience :: Science/Research',
+ 'Topic :: Scientific/Engineering :: Human Machine Interfaces',
+ 'License :: OSI Approved :: GNU General Public License v3 (GPLv3)',
+ 'Programming Language :: Python :: 3',
+ 'Operating System :: OS Independent'
+]
+dependencies = [
+ 'opencv-python>=4.7.0',
+ 'opencv-contrib-python>=4.7.0',
+ 'numpy',
+ 'pandas',
+ 'av',
+ 'colorama',
+ 'matplotlib',
+ 'shapely',
+ 'lempel_ziv_complexity',
+ 'scipy',
+ 'scikit-learn'
+]
+dynamic = ["version"]
+
+[project.scripts]
+demo="argaze ./src/argaze/utils/demo/ opencv_window_context_setup.json" \ No newline at end of file