aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorThéo de la Hogue2024-04-10 16:09:26 +0200
committerThéo de la Hogue2024-04-10 16:09:26 +0200
commit2e2f02e3c8847788f000926c8e8eb3980d6637c3 (patch)
treeba5492367d3b7843504af3621fe7daf8281ea0a3 /pyproject.toml
parent9994f7f9ddcf94ee0c6bab67761e714e9025bd6f (diff)
downloadargaze-2e2f02e3c8847788f000926c8e8eb3980d6637c3.zip
argaze-2e2f02e3c8847788f000926c8e8eb3980d6637c3.tar.gz
argaze-2e2f02e3c8847788f000926c8e8eb3980d6637c3.tar.bz2
argaze-2e2f02e3c8847788f000926c8e8eb3980d6637c3.tar.xz
Fixing pyproject.toml. Updating installation documentation.
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml53
1 files changed, 25 insertions, 28 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 54f342b..383e156 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,19 +1,17 @@
[build-system]
requires = [
- "setuptools",
+ "setuptools"
]
build-backend = "setuptools.build_meta"
[project]
name = "argaze"
+version = "0.0.7"
authors = [
- {
- name = 'ACHIL laboratory at Ecole Nationale de l\'Aviation Civile (ENAC)',
- email = 'argaze-contact@recherche.enac.fr'
- }
+ {"name" = "ACHIL laboratory at Ecole Nationale de l'Aviation Civile (ENAC)", "email" = "argaze-contact@recherche.enac.fr"}
]
description = "An Open and Flexible Software Library for Gaze Analysis and Interaction."
-readme= "README.md"
+readme= {file = "README.md", content-type = "text/markdown"}
requires-python = ">=3.11"
keywords=[
"eye tracking",
@@ -21,30 +19,29 @@ keywords=[
"real-time",
"modular"
]
-license = {text = "GPLv3"}
+license = {file = "LICENSE"}
classifiers=[
- 'Development Status :: 3 - Alpha',
- 'Intended Audience :: Developers',
- 'Intended Audience :: Science/Research',
- 'Topic :: Scientific/Engineering :: Human Machine Interfaces',
- 'License :: OSI Approved :: GNU General Public License v3 (GPLv3)',
- 'Programming Language :: Python :: 3',
- 'Operating System :: OS Independent'
+ "Development Status :: 3 - Alpha",
+ "Intended Audience :: Developers",
+ "Intended Audience :: Science/Research",
+ "Topic :: Scientific/Engineering :: Human Machine Interfaces",
+ "License :: OSI Approved :: GNU General Public License v3 (GPLv3)",
+ "Programming Language :: Python :: 3",
+ "Operating System :: OS Independent"
]
dependencies = [
- 'opencv-python>=4.7.0',
- 'opencv-contrib-python>=4.7.0',
- 'numpy',
- 'pandas',
- 'av',
- 'colorama',
- 'matplotlib',
- 'shapely',
- 'lempel_ziv_complexity',
- 'scipy',
- 'scikit-learn'
+ "opencv-python>=4.7.0",
+ "opencv-contrib-python>=4.7.0",
+ "numpy",
+ "pandas",
+ "av",
+ "colorama",
+ "matplotlib",
+ "shapely",
+ "lempel_ziv_complexity",
+ "scipy",
+ "scikit-learn"
]
-dynamic = ["version"]
[project.urls]
Homepage = "https://gitpub.recherche.enac.fr/argaze"
@@ -52,5 +49,5 @@ Documentation = "http://achil.recherche.enac.fr/features/eye/argaze/index.html"
Repository = "https://gitpub.recherche.enac.fr/argaze"
Issues = "https://git.recherche.enac.fr/projects/argaze/issues"
-[project.scripts]
-demo="argaze ./src/argaze/utils/demo/ opencv_window_context_setup.json" \ No newline at end of file
+[tool.setuptools]
+package-dir = {"" = "src"}