summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authordamiano1999-04-26 15:26:06 +0000
committerdamiano1999-04-26 15:26:06 +0000
commit4782c96923bd5cc9b072b0e672f1420c93fd19dd (patch)
tree87bf5d3a26976e95c188a94f06f6019b1ccd98a7 /debian/rules
parent0a462da394768938733d34b4ca724fb9260be51e (diff)
downloadirbox-4782c96923bd5cc9b072b0e672f1420c93fd19dd.zip
irbox-4782c96923bd5cc9b072b0e672f1420c93fd19dd.tar.gz
irbox-4782c96923bd5cc9b072b0e672f1420c93fd19dd.tar.bz2
irbox-4782c96923bd5cc9b072b0e672f1420c93fd19dd.tar.xz
Debianisation
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules69
1 files changed, 69 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..ad200dd
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,69 @@
+#!/usr/bin/make -f
+# Made with the aid of debmake, by Christoph Lameter,
+# based on the sample debian/rules file for GNU hello by Ian Jackson.
+
+package=irbox
+SED_COMMAND='s/.*(\([^)]*\)-.*/\1/p'
+VERSION := $(shell sed -n $(SED_COMMAND) debian/changelog | head -1)
+CVS_TAG := V$(shell echo -n $(VERSION) | sed -n 's/\./_/gp')
+
+build:
+ $(checkdir)
+
+ cd src && make
+ touch build
+
+clean:
+ $(checkdir)
+ -rm -f build
+ -cd src && make clean
+ -rm -f `find . -name "*~"`
+ -rm -rf debian/tmp debian/files* core debian/substvars
+
+binary-indep: checkroot build
+ $(checkdir)
+# There are no architecture-independent files to be uploaded
+# generated by this package. If there were any they would be
+# made here.
+
+binary-arch: checkroot build
+ $(checkdir)
+ $(checkversion)
+ -rm -rf debian/tmp
+ install -d debian/tmp
+ cd debian/tmp && install -d `cat ../dirs`
+ cd src && make install PREFIX=`pwd`/../debian/tmp
+# Must have debmake installed for this to work. Otherwise please copy
+# /usr/bin/debstd into the debian directory and change debstd to debian/debstd
+ debstd doc/ChangeLog
+ dpkg-gencontrol
+ chown -R root.root debian/tmp
+ chmod -R go=rX debian/tmp
+ dpkg --build debian/tmp ..
+
+define checkdir
+ test -f debian/rules
+endef
+
+binary: binary-indep binary-arch
+
+checkroot:
+ $(checkdir)
+ test root = "`whoami`"
+
+define checkversion
+ -@if (test -d CVS); then \
+ if (cvs status -v debian/changelog | grep --silent $(CVS_TAG)); then \
+ echo "cvs tag $(CVS_TAG) matches package version $(VERSION)"; \
+ else \
+ echo "debian/rules: *** Warning : No cvs tag $(CVS_TAG) matches package version $(VERSION) for file changelog. You can tag your cvs module by doing debian/rules tag"; \
+ echo -n "debian/rules: *** Existing tags are : "; \
+ cvs status -v debian/changelog | sed -n 's/.*\(V.*_[0-9]\).*/\1/p'; \
+ fi \
+ fi
+endef
+
+tag:
+ -@if (test -x `which cvs`); then cvs tag $(CVS_TAG) .; fi
+
+.PHONY: binary binary-arch binary-indep clean checkroot