summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authormertz2000-03-10 16:41:59 +0000
committermertz2000-03-10 16:41:59 +0000
commit0335c21b7fc879ecf2f659f530d01b9386aa8cdb (patch)
treeb797c4671125a3357d0a31de78a9edbea18ddbff /debian/rules
parentd7ceb335cb64f3d28c040a3104e10b8d54590386 (diff)
downloadivy-c-0335c21b7fc879ecf2f659f530d01b9386aa8cdb.zip
ivy-c-0335c21b7fc879ecf2f659f530d01b9386aa8cdb.tar.gz
ivy-c-0335c21b7fc879ecf2f659f530d01b9386aa8cdb.tar.bz2
ivy-c-0335c21b7fc879ecf2f659f530d01b9386aa8cdb.tar.xz
html docs are re-included in /usr/share/doc
libtclivy works again... (didn't work anymore due to library rename)
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules11
1 files changed, 6 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index 9cdec42..30c9627 100755
--- a/debian/rules
+++ b/debian/rules
@@ -16,7 +16,7 @@ build:
clean:
$(checkdir)
-rm -f build
- -rm -rf debian/tmp `find debian/* -type d ! -name CVS` debian/files* core
+ -rm -rf debian/tmp debian/*~ debian/copyright `find debian/* -type d ! -name CVS` debian/files* core
-rm -f debian/*substvars
cd src && make clean
@@ -33,12 +33,13 @@ binary-arch: checkroot build
cd debian/tmp && install -d `cat ../dirs`
cd src && make installlibs PREFIX=`pwd`/../debian/tmp MAJOR=$(MAJOR) MINOR=$(MINOR)
+ cd src && make installbins PREFIX=`pwd`/../debian/tmp
-rm debian/tmp/usr/include/list.h # it's yet in utils-c-dev
-cp src/version.h debian/copyright
- -strip --strip-unneeded debian/tmp/usr/lib/libivy.so.$(MAJOR).$(MINOR)
- -strip --strip-unneeded debian/tmp/usr/lib/libtclivy.so.$(MAJOR).$(MINOR)
- -strip --strip-unneeded debian/tmp/usr/X11R6/lib/libxtivy.so.$(MAJOR).$(MINOR)
+ dh_strip debian/tmp/usr/lib/libivy.so.$(MAJOR).$(MINOR)
+ dh_strip debian/tmp/usr/lib/libtclivy.so.$(MAJOR).$(MINOR)
+ dh_strip debian/tmp/usr/X11R6/lib/libxtivy.so.$(MAJOR).$(MINOR)
dh_link usr/lib/libivy.so.$(MAJOR).$(MINOR) usr/lib/libivy.so.$(MAJOR)
dh_link usr/lib/libgivy.so.$(MAJOR).$(MINOR) usr/lib/libgivy.so.$(MAJOR)
@@ -51,7 +52,7 @@ binary-arch: checkroot build
dh_fixperms
- debstd
+ debstd doc/man-ivy-c.html doc/ivy-c-*.html
-rmdir debian/tmp/usr/include