summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authordamiano1999-04-13 14:55:34 +0000
committerdamiano1999-04-13 14:55:34 +0000
commit7c1946450461d32e60e0860fd89437e602173a7f (patch)
tree1975efd519f1a6dfb788f7c6e07da5ac0d5ff8fc /debian/rules
parent45f7b5eef5a2108242e24cc76ae6c400a6b3da9e (diff)
downloadivy-c-7c1946450461d32e60e0860fd89437e602173a7f.zip
ivy-c-7c1946450461d32e60e0860fd89437e602173a7f.tar.gz
ivy-c-7c1946450461d32e60e0860fd89437e602173a7f.tar.bz2
ivy-c-7c1946450461d32e60e0860fd89437e602173a7f.tar.xz
Correcting bug regarding cvs tag
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 2 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 40c7f3f..2529da7 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,7 +8,7 @@ SED_COMMAND='s/.*(\([^)]*\)).*/\1/p'
MAJOR := $(shell sed -n $(SED_COMMAND) debian/changelog | head -1 | sed -n 's/\([0-9]*\)\..*/\1/p')
MINOR := $(shell sed -n $(SED_COMMAND) debian/changelog | head -1 | sed -n 's/[0-9]*\.\([0-9\.]*\).*/\1/p')
VERSION = $(MAJOR).$(MINOR)
-CVS_TAG := $(shell echo -n $(VERSION) | sed -n 's/\./_/gp')
+CVS_TAG := V$(shell echo -n $(VERSION) | sed -n 's/\./_/gp')
build:
$(checkdir)
@@ -75,6 +75,6 @@ define checkversion
endef
tag:
- -@if (test -x cvs); then cvs tag $(CVS_TAG) .; fi
+ -@if (test -x `which cvs`); then cvs tag $(CVS_TAG) .; fi
.PHONY: binary binary-arch binary-indep clean checkroot