summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authordamiano1998-12-22 17:19:28 +0000
committerdamiano1998-12-22 17:19:28 +0000
commit82bada47316b25fb6c3755680414f32884caf0e5 (patch)
tree50764649139750a6483cc2d26b54667f1912d00a /debian/rules
parent575471fc017dcbccfc767d062facb61ca5835c5a (diff)
downloadivy-c-82bada47316b25fb6c3755680414f32884caf0e5.zip
ivy-c-82bada47316b25fb6c3755680414f32884caf0e5.tar.gz
ivy-c-82bada47316b25fb6c3755680414f32884caf0e5.tar.bz2
ivy-c-82bada47316b25fb6c3755680414f32884caf0e5.tar.xz
Debianisation des sources de la version de Stéphane C
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 3 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index 00dfae6..d5e8861 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,8 +4,8 @@
package=ivy-c
-version=$(shell expr `pwd` : '.*-\([0-9.]*\)')
-version_major=$(shell expr `pwd` : '.*-\([0-9]*\).[0-9.]*')
+VERSION=`sed -n 's/.*(\([^)]*\)).*/\1/p' changelog | head -1 | sed -n 's/\([0-9]*\)\..*/\1/p'`
+MAJOR_MINOR=`sed -n 's/.*(\([^)]*\)).*/\1/p' changelog | head -1 | sed -n 's/[0-9]*\.\([0-9\.]*\).*/\1/p'`
build:
$(checkdir)
@@ -33,7 +33,7 @@ binary-arch: checkroot build
install -d debian/tmp
cd debian/tmp && install -d `cat ../dirs`
- cd src && make install DESTDIR=`pwd`/../debian/tmp
+ cd src && make install DESTDIR=`pwd`/../debian/tmp VERSION=$(VERSION) MAJOR=$(MAJOR) MINOR=$MINOR
debstd
-rmdir debian/tmp/usr/include