summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorbustico2013-05-06 15:55:23 +0000
committerbustico2013-05-06 15:55:23 +0000
commita5d7e0be2570bd5250da6141fc75db8690a26c52 (patch)
treec65d8cfd64c2a54eb84039d0dcbfe83bbd729493 /debian/rules
parent28a7e628b8b5411441b178480e1dcfa40e9930c8 (diff)
downloadivy-c-a5d7e0be2570bd5250da6141fc75db8690a26c52.zip
ivy-c-a5d7e0be2570bd5250da6141fc75db8690a26c52.tar.gz
ivy-c-a5d7e0be2570bd5250da6141fc75db8690a26c52.tar.bz2
ivy-c-a5d7e0be2570bd5250da6141fc75db8690a26c52.tar.xz
some Makefile and debian build fixes
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules72
1 files changed, 17 insertions, 55 deletions
diff --git a/debian/rules b/debian/rules
index e175365..6937537 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,70 +1,32 @@
#!/usr/bin/make -f
-# Made with the aid of debmake, by Christoph Lameter,
-# based on the sample debian/rules file for GNU hello by Ian Jackson.
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
# Uncomment this to turn on verbose mode.
-export DH_VERBOSE=1
+#export DH_VERBOSE=1
+
+%:
+ dh $@
+
SED_COMMAND='s/.*(\([^)]*\)).*/\1/p'
MAJOR := $(shell sed -n $(SED_COMMAND) debian/changelog | head -1 | sed -n 's/\([0-9]*\)\..*/\1/p')
MINOR := $(shell sed -n $(SED_COMMAND) debian/changelog | head -1 | sed -n 's/[0-9]*\.\([0-9\.]*\).*/\1/p')
-configure: configure-stamp
-configure-stamp:
- dh_testdir
- # Add here commands to configure the package.
- touch configure-stamp
-
-build: build-stamp
-build-stamp: configure-stamp
- dh_testdir
- cd src && $(MAKE) all MAJOR=$(MAJOR) MINOR=$(MINOR) TCLINC=$(-I/usr/include/tcl8.4/) TCLLIB=$(-ltcl8.4) CFLAGS="-g -fPIC -D_REENTRANT" LDFLAGS="-L/usr/X11R6/lib"
- touch build-stamp
+override_dh_auto_build :
+ cd src && $(MAKE) all MAJOR=$(MAJOR) MINOR=$(MINOR) CFLAGS="-g -fPIC -D_REENTRANT"
-clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp configure-stamp
+override_dh_auto_clean :
cd src && $(MAKE) clean
- dh_clean
-install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
+override_dh_auto_install :
cd src && $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp PREFIX=/usr LIB=/lib
-binary-indep: build install
-binary-arch: build install
- dh_testdir
- dh_testroot
- dh_installchangelogs
- dh_installdocs
- dh_installexamples
+override_dh_auto_binary-arch:
dh_install --source=$(CURDIR)/debian/tmp
-# dh_installmenu
-# dh_installdebconf
-# dh_installlogrotate
-# dh_installemacsen
-# dh_installpam
-# dh_installmime
-# dh_installinit
-# dh_installcron
-# dh_installinfo
- dh_installman
- dh_link
-# dh_strip
- dh_compress
- dh_fixperms
-# dh_perl
-# dh_python
- dh_makeshlibs
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
+.PHONY: override_dh_auto_build override_dh_auto_clean override_dh_auto_install override_dh_auto_binary-arch