summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authordamiano2000-01-19 17:09:55 +0000
committerdamiano2000-01-19 17:09:55 +0000
commitcd2730a241e924454bae373493968a3f31674ccd (patch)
treec4dbc06f41b3aa1381a037fc8e4938c77d8554bb /debian/rules
parent02e638eb51cfdf5156cb465771d7fbccec01066e (diff)
downloadivy-c-cd2730a241e924454bae373493968a3f31674ccd.zip
ivy-c-cd2730a241e924454bae373493968a3f31674ccd.tar.gz
ivy-c-cd2730a241e924454bae373493968a3f31674ccd.tar.bz2
ivy-c-cd2730a241e924454bae373493968a3f31674ccd.tar.xz
New Makefile => new version
add dependancy to tcl in control add libtcl.so and libtcl.a in ivy-c-dev.files Massive changes to match potato debian policy in rules remove of /usr/doc in dirs remove of debian/copyright. A copy of src/version.h to debian/copyright is done at build time
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules56
1 files changed, 24 insertions, 32 deletions
diff --git a/debian/rules b/debian/rules
index 335a5b2..f45b1d1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,24 +2,19 @@
# Made with the aid of debmake, by Christoph Lameter,
# based on the sample debian/rules file for GNU hello by Ian Jackson.
-package=ivy-c
-
SED_COMMAND='s/.*(\([^)]*\)).*/\1/p'
MAJOR := $(shell sed -n $(SED_COMMAND) debian/changelog | head -1 | sed -n 's/\([0-9]*\)\..*/\1/p')
MINOR := $(shell sed -n $(SED_COMMAND) debian/changelog | head -1 | sed -n 's/[0-9]*\.\([0-9\.]*\).*/\1/p')
-VERSION = $(MAJOR).$(MINOR)
-CVS_TAG := V$(shell echo -n $(VERSION) | sed -n 's/\./_/gp')
+
+package=ivy-c
build:
$(checkdir)
-# $(checkversion)
- cd src && make all MAJOR=$(MAJOR) MINOR=$(MINOR)
-
+ cd src && make all MAJOR=$(MAJOR) MINOR=$(MINOR) CFLAGS="-g -fPIC -D_REENTRANT"
touch build
clean:
$(checkdir)
-# $(checkversion)
-rm -f build
-rm -rf debian/tmp `find debian/* -type d ! -name CVS` debian/files* core
-rm -f debian/*substvars
@@ -27,26 +22,40 @@ clean:
binary-indep: checkroot build
$(checkdir)
-# $(checkversion)
# There are no architecture-independent files to be uploaded
# generated by this package. If there were any they would be
# made here.
binary-arch: checkroot build
$(checkdir)
-# $(checkversion)
-rm -rf debian/tmp `find debian/* -type d ! -name CVS`
install -d debian/tmp
cd debian/tmp && install -d `cat ../dirs`
- cd src && make install PREFIX=`pwd`/../debian/tmp MAJOR=$(MAJOR) MINOR=$(MINOR)
+ cd src && make installlibs PREFIX=`pwd`/../debian/tmp MAJOR=$(MAJOR) MINOR=$(MINOR)
+
+ -rm debian/tmp/usr/include/list.h # it's yet in utils-c-dev
+ -cp src/version.h debian/copyright
+ -strip --strip-unneeded debian/tmp/usr/lib/libivy.so.$(MAJOR).$(MINOR)
+ -strip --strip-unneeded debian/tmp/usr/lib/libtclivy.so.$(MAJOR).$(MINOR)
+ -strip --strip-unneeded debian/tmp/usr/X11R6/lib/libxtivy.so.$(MAJOR).$(MINOR)
+
+ dh_link usr/lib/libivy.so.$(MAJOR).$(MINOR) usr/lib/libivy.so.$(MAJOR)
+ dh_link usr/lib/libgivy.so.$(MAJOR).$(MINOR) usr/lib/libgivy.so.$(MAJOR)
+ dh_link usr/lib/libtclivy.so.$(MAJOR).$(MINOR) usr/lib/libtclivy.so.$(MAJOR)
+ dh_link usr/X11R6/lib/libxtivy.so.$(MAJOR).$(MINOR) usr/X11R6/lib/libxtivy.so.$(MAJOR)
+ dh_link usr/lib/libivy.so.$(MAJOR).$(MINOR) usr/lib/libivy.so
+ dh_link usr/lib/libgivy.so.$(MAJOR).$(MINOR) usr/lib/libgivy.so
+ dh_link usr/lib/libtclivy.so.$(MAJOR).$(MINOR) usr/lib/libtclivy.so
+ dh_link usr/lib/libxtivy.so.$(MAJOR).$(MINOR) usr/X11R6/lib/libxtivy.so
+
+ dh_fixperms
+
+ debstd
- debstd -p doc/*.html doc/ChangeLog doc/NEWS doc/TODO doc/BUGS doc/README
-rmdir debian/tmp/usr/include
- dpkg-gencontrol -p$(package)
- chown -R root.root debian/tmp
- chmod -R go=rX debian/tmp
+ dpkg-gencontrol -p$(package) -isp
dpkg --build debian/tmp ..
define checkdir
@@ -61,21 +70,4 @@ checkroot:
$(checkdir)
test root = "`whoami`"
-define checkversion
- -@echo $(VERSION)
- -@echo $(CVS_TAG)
- -@if (test -d CVS); then \
- if (cvs status -v debian/changelog | grep --silent $(CVS_TAG)); then \
- echo "cvs tag $(CVS_TAG) matches package version $(VERSION)"; \
- else \
- echo "debian/rules: *** Warning : No cvs tag $(CVS_TAG) matches package version $(VERSION) for file changelog. You can tag your cvs module by doing debian/rules tag"; \
- echo -n "debian/rules: *** Existing tags are : "; \
- cvs status -v debian/changelog | sed -n 's/.*\(V.*_[0-9]\).*/\1/p'; \
- fi \
- fi
-endef
-
-tag:
- -@if (test -x `which cvs`); then cvs tag $(CVS_TAG) .; fi
-
.PHONY: binary binary-arch binary-indep clean checkroot