summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authordamiano1998-12-28 12:35:34 +0000
committerdamiano1998-12-28 12:35:34 +0000
commitff5b5d047fc3e237ad49e0673ee30d380505d511 (patch)
treeb21273f9997e9e7abb8a7508dcc11917a9b59907 /debian/rules
parent96996ed16f3bf4d9e6b0fc070c8a0d018503c130 (diff)
downloadivy-c-ff5b5d047fc3e237ad49e0673ee30d380505d511.zip
ivy-c-ff5b5d047fc3e237ad49e0673ee30d380505d511.tar.gz
ivy-c-ff5b5d047fc3e237ad49e0673ee30d380505d511.tar.bz2
ivy-c-ff5b5d047fc3e237ad49e0673ee30d380505d511.tar.xz
Correction sur debian/rules et src/Makefile
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules8
1 files changed, 5 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index 53a7e3e..6b5213a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,8 +4,10 @@
package=ivy-c
-VERSION=`sed -n 's/.*(\([^)]*\)).*/\1/p' debian/changelog | head -1 | sed -n 's/\([0-9]*\)\..*/\1/p'`
-MAJOR_MINOR=`sed -n 's/.*(\([^)]*\)).*/\1/p' debian/changelog | head -1 | sed -n 's/[0-9]*\.\([0-9\.]*\).*/\1/p'`
+SED_COMMAND_VERSION='s/.*(\([^)]*\)).*/\1/p'
+VERSION := $(shell sed -n $(SED_COMMAND_VERSION) debian/changelog | head -1 | sed -n 's/\([0-9]*\)\..*/\1/p')
+SED_COMMAND_MAJOR_MINOR='s/.*(\([^)]*\)).*/\1/p'
+MAJOR_MINOR := $(shell sed -n $(SED_COMMAND_MAJOR_MINOR) debian/changelog | head -1 | sed -n 's/[0-9]*\.\([0-9\.]*\).*/\1/p')
build:
$(checkdir)
@@ -33,7 +35,7 @@ binary-arch: checkroot build
install -d debian/tmp
cd debian/tmp && install -d `cat ../dirs`
- cd src && make install DESTDIR=`pwd`/../debian/tmp VERSION=$(VERSION) MAJOR=$(MAJOR) MINOR=$MINOR
+ cd src && make install DESTDIR=`pwd`/../debian/tmp VERSION=$(VERSION) MAJOR_MINOR=$(MAJOR_MINOR)
debstd
-rmdir debian/tmp/usr/include