summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorlecoanet1998-12-11 17:24:48 +0000
committerlecoanet1998-12-11 17:24:48 +0000
commit25c512868d7948bc02ba91e9f06d398c31b0bedf (patch)
treedef6b2544cf3c81068bac6788f4ab9465de236b7 /debian
parent34ace791502635f9bc725192bc609994e9f9b730 (diff)
downloadivy-c-25c512868d7948bc02ba91e9f06d398c31b0bedf.zip
ivy-c-25c512868d7948bc02ba91e9f06d398c31b0bedf.tar.gz
ivy-c-25c512868d7948bc02ba91e9f06d398c31b0bedf.tar.bz2
ivy-c-25c512868d7948bc02ba91e9f06d398c31b0bedf.tar.xz
Modification pour debianisation
Diffstat (limited to 'debian')
-rw-r--r--debian/README5
-rw-r--r--debian/changelog17
-rw-r--r--debian/control19
-rw-r--r--debian/copyright8
-rw-r--r--debian/dirs6
-rw-r--r--debian/ivy-c-dev.files7
-rwxr-xr-xdebian/rules58
7 files changed, 120 insertions, 0 deletions
diff --git a/debian/README b/debian/README
new file mode 100644
index 0000000..2a37219
--- /dev/null
+++ b/debian/README
@@ -0,0 +1,5 @@
+
+Construction de ivy-c :
+
+ - Il faut installer au préalable le paquetage utils-c-dev qui
+ fourni list.h.
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..6689ef1
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,17 @@
+ivy-c (1.1-2) unstable; urgency=low
+
+ * Suppression du header list.h qui est aussi défini dans utils-c.
+ * Ajout du soname à la bibliothèque dynamique.
+
+ -- Patrick Lecoanet <lecoanet@cena.dgac.fr> Wed, 9 Dec 1998 11:24:34 +0100
+
+ivy-c (1.1-1) unstable; urgency=low
+
+ * Initial Release.
+
+ -- Patrick Lecoanet <lecoanet@cena.dgac.fr> Tue, 13 Oct 1998 09:52:30 +0200
+
+Local variables:
+mode: debian-changelog
+add-log-mailing-address: "lecoanet@cena.dgac.fr"
+End:
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..8cd21eb
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,19 @@
+Source: ivy-c
+Section: devel
+Priority: extra
+Maintainer: Patrick Lecoanet <lecoanet@cena.dgac.fr>
+Standards-Version: 2.3.0.0
+
+Package: ivy-c
+Architecture: any
+Depends: ${shlibs:Depends}
+Description: Bus logiciel PII.
+ Bus logiciel PII. Fichiers de runtime.
+
+Package: ivy-c-dev
+Architecture: any
+Depends: ivy-c, libc6-dev, xlib6g-dev
+Provides: ivy-c-dev
+Conflicts: ivy-c-dev
+Description: Bus logiciel PII.
+ Bus logiciel PII. Fichiers nécessaires au développement.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..28c4502
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,8 @@
+This package was debianized by Patrick Lecoanet lecoanet@cena.dgac.fr on
+Tue, 13 Oct 1998 09:52:30 +0200.
+
+It was downloaded from <fill in ftp site>
+
+Copyright:
+
+<Must follow here>
diff --git a/debian/dirs b/debian/dirs
new file mode 100644
index 0000000..082722d
--- /dev/null
+++ b/debian/dirs
@@ -0,0 +1,6 @@
+usr/lib
+usr/bin
+usr/X11R6/lib
+usr/X11R6/bin
+usr/include
+usr/man/man3
diff --git a/debian/ivy-c-dev.files b/debian/ivy-c-dev.files
new file mode 100644
index 0000000..8bf1137
--- /dev/null
+++ b/debian/ivy-c-dev.files
@@ -0,0 +1,7 @@
+usr/include
+usr/lib/libivy.a
+usr/lib/libivy.so
+usr/lib/libgivy.a
+usr/lib/libgivy.so
+usr/X11R6/lib/libxtivy.a
+usr/X11R6/lib/libxtivy.so
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..00dfae6
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,58 @@
+#!/usr/bin/make -f
+# Made with the aid of debmake, by Christoph Lameter,
+# based on the sample debian/rules file for GNU hello by Ian Jackson.
+
+package=ivy-c
+
+version=$(shell expr `pwd` : '.*-\([0-9.]*\)')
+version_major=$(shell expr `pwd` : '.*-\([0-9]*\).[0-9.]*')
+
+build:
+ $(checkdir)
+
+ cd src && make all
+
+ touch build
+
+clean:
+ $(checkdir)
+ -rm -f build
+
+ -rm -rf debian/tmp `find debian/* -type d ! -name CVS` debian/files* core
+ -rm -f debian/*substvars
+
+binary-indep: checkroot build
+ $(checkdir)
+# There are no architecture-independent files to be uploaded
+# generated by this package. If there were any they would be
+# made here.
+
+binary-arch: checkroot build
+ $(checkdir)
+ -rm -rf debian/tmp `find debian/* -type d`
+ install -d debian/tmp
+ cd debian/tmp && install -d `cat ../dirs`
+
+ cd src && make install DESTDIR=`pwd`/../debian/tmp
+
+ debstd
+ -rmdir debian/tmp/usr/include
+
+ dpkg-gencontrol -p$(package)
+ chown -R root.root debian/tmp
+ chmod -R go=rX debian/tmp
+ dpkg --build debian/tmp ..
+
+define checkdir
+ test -f debian/rules
+endef
+
+# Below here is fairly generic really
+
+binary: binary-indep binary-arch
+
+checkroot:
+ $(checkdir)
+ test root = "`whoami`"
+
+.PHONY: binary binary-arch binary-indep clean checkroot