aboutsummaryrefslogtreecommitdiff
path: root/debian/changelog
diff options
context:
space:
mode:
authorjestin2004-07-27 16:20:45 +0000
committerjestin2004-07-27 16:20:45 +0000
commit071a0d6be6ebb591776786ff430378cfcbf385db (patch)
tree64ba5fe6fee8182982ef0a0e477735df1ba2e920 /debian/changelog
parentdbfd0856406b93d34d2b9a4b72512ef38b81970b (diff)
downloadivy-java-071a0d6be6ebb591776786ff430378cfcbf385db.zip
ivy-java-071a0d6be6ebb591776786ff430378cfcbf385db.tar.gz
ivy-java-071a0d6be6ebb591776786ff430378cfcbf385db.tar.bz2
ivy-java-071a0d6be6ebb591776786ff430378cfcbf385db.tar.xz
changelog synced with upstream changelog. Added xml and txt example files in
the debian rules. Changed the name of the package from ivy-java to libivy-java
Diffstat (limited to 'debian/changelog')
-rw-r--r--debian/changelog71
1 files changed, 71 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 7639608..5e89490 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,74 @@
+libivy-java (1.2.6) unstable; urgency=low
+
+ debian package
+ - the package name goes to libivy-java,
+ - examples have been added in the documentation and corrected to honor the
+ new lib
+
+ documentation
+ - the manual has been heavily updated, and C++ has been left out.
+
+ new features
+ - use Ivy.protectNewLine(true) to ensure encoding and decoding of newline
+ as 0x1A. As the encoding and decoding cost a little more CPU and is not
+ yet standardized in the Ivy protocol, use it at your own risk.
+ - IvyClient now sends back an error message when an incorrect regexp is sent
+ the message is supposed to be readable
+ - uses apache jakarta-regexp instead of gnu-regexp ( see
+ http://jakarta.apache.org/regexp/ ), we gain a compatibility with Perl
+ and the new ivy-c 3.4.6 :)
+ - no more java ping in Probe ...
+ - use bindAsyncMsg(regexp) to perform each regexp in a new Thread. This
+ can avoid hangups when you have lengthy callbacks ( calculation, etc ).
+ There is no asynchronous sending of message because the tests are sooooo
+ unsuccessful
+
+ API changes
+ - Ivy changed changed the semantic of -b a,b:port,c:otherport if no port is
+ specified for a, it take the port from the next one. If none is
+ specified, it takes DEFAULT_PORT
+ - IvyWatcher's getDomain now sends IvyException for malformed broadcast addresses
+
+ -- Yannick Jestin <jestin@cena.fr> Tue, 27 Aug 2004 16:49:00 +0100
+
+ivy-java (1.2.4) unstable; urgency=low
+
+ bugfixes
+ - resists when a non Ivy Agent broadcasts on our address
+ - invokes disconnect() on a normal IvyClient end of run()
+ - bus.start(null) now *really* starts on IVYBUS property or 127:2010 if the
+ property is not set
+ - bugfix J007 : breaks connexions with remote clients using a faulty
+ protocol, ignore subscriptions to faulty regexps.
+ - bugfix J006 : invokes the applicationListeners's disconnect method at the
+ end of the run() loop
+ - the IvyWatcher accepts connexions from remote hosts with the same port
+ number. Closes a possible bug, yet to check thoroughfully...
+ - bugfix J005 : the IvyWatcher's loop doesn't break on faulty broadcasts,
+ belonging to non ivy application, e.g.
+ - major rewrite of the internals of the Ivy class structure
+
+ new features
+ - added a sendToSelf(boolean) method in the Ivy class to allow the
+ sendMsg() to trigger our own callbacks. Default is false.
+
+ API Changes (WARNING, you might have to recompile you applications)
+ - changed the API for Ivy.sendMsg and IvyClient.sendDirectMsg, both function
+ can now raise an IvyException if the message contains \n or \0x3
+ - changed the API for IvyApplicationListener ( die now requires a String
+ argument ).
+ - changed the API for Ivy.bindMsg(). It now raises an IvyException if the
+ regexp was not compiled successfully (e.g.: "(.*").
+ - added an IvyBindListener and Ivy.addBindListener, Ivy.removeBindListener
+ order to hook callbacks upon reception of bind requests. It is now
+ possible to write a decent ivy monitor program. JProbe has been rewritten
+ this way and now displays the subscriptions in real time, not only at
+ startup ( should I file a bugreport against ivy-c ? )
+ - Probe can send messages to itself, with the -s command line switch
+
+
+ -- Yannick Jestin <jestin@cena.fr> Tue, 18 Feb 2003 16:49:00 +0100
+
ivy-java (1.2.3) unstable; urgency=low
- debian packaging corrected, now build-depends on java-compiler and