aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 10 insertions, 6 deletions
diff --git a/debian/rules b/debian/rules
index 6827cc6..f09e0b2 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,10 +1,11 @@
#!/usr/bin/make -f
# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+include /usr/share/ocaml/ocamlvars.mk
+
+DEB_DESTDIR = $(CURDIR)/debian/ivy-ocaml
+DEB_OCAML_DESTDIR = $(DEB_DESTDIR)$(OCAML_STDLIB_DIR)
+export OCAMLFIND_DESTDIR = $(DEB_OCAML_DESTDIR)
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
@@ -13,5 +14,8 @@
dh $@ --with ocaml
override_dh_auto_install :
- $(MAKE) install DESTDIR=$(CURDIR)/debian/ivy-ocaml
+ mkdir -p $(DEB_OCAML_DESTDIR)
+ mkdir -p $(DEB_OCAML_DESTDIR)/stublibs
+ $(MAKE) DESTDIR=$(DEB_DESTDIR) install
+.PHONY: override_dh_auto_install