summaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authormertz2001-01-04 13:12:24 +0000
committermertz2001-01-04 13:12:24 +0000
commit0dc6d388288b58c28310765422981d8fc94cc553 (patch)
treeac9f7f0f3671cddc65e94b0b39cca409f6988a67 /Makefile.PL
parentf7893eb6c5aaf8f16bf58a2daf9d89bec19b9caf (diff)
downloadivy-perl-0dc6d388288b58c28310765422981d8fc94cc553.zip
ivy-perl-0dc6d388288b58c28310765422981d8fc94cc553.tar.gz
ivy-perl-0dc6d388288b58c28310765422981d8fc94cc553.tar.bz2
ivy-perl-0dc6d388288b58c28310765422981d8fc94cc553.tar.xz
Makefile.PL (and debian/rules are enhanced to take into account the ivyprobe.pl script and to install it in /usr/bin/
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
index b3f287f..c1a0bc0 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -4,4 +4,10 @@ use ExtUtils::MakeMaker;
WriteMakefile(
'NAME' => 'Ivy',
'VERSION_FROM' => 'Ivy.pm', # finds $VERSION
+ 'PREREQ_PM' => {
+ 'Time::Gettimeofday' => 0.01,
+ },
+ 'PM' => {'Ivy.pm' => '$(INST_LIBDIR)/Ivy.pm'},
+
+ 'EXE_FILES' => [ qw(example/ivyprobe.pl) ],
);