summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authordamiano1999-12-22 13:35:52 +0000
committerdamiano1999-12-22 13:35:52 +0000
commit757e49647319eb5e30d7f392c84e20c75b06f70f (patch)
tree973d8d9fa630d7d6f092a215102526315e3ddfa9 /debian/rules
parentbe621edb9756813baf0b73ca89bc4d108cbfcd2b (diff)
downloadivy-perl-757e49647319eb5e30d7f392c84e20c75b06f70f.zip
ivy-perl-757e49647319eb5e30d7f392c84e20c75b06f70f.tar.gz
ivy-perl-757e49647319eb5e30d7f392c84e20c75b06f70f.tar.bz2
ivy-perl-757e49647319eb5e30d7f392c84e20c75b06f70f.tar.xz
Match potato perl policy
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules43
1 files changed, 16 insertions, 27 deletions
diff --git a/debian/rules b/debian/rules
index 37f46df..083b105 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,35 +3,39 @@
# based on the sample debian/rules file for GNU hello by Ian Jackson.
package=ivy-perl
-SED_COMMAND='s/.*(\([^)]*\)-.*/\1/p'
-VERSION := $(shell sed -n $(SED_COMMAND) debian/changelog | head -1)
-CVS_TAG := V$(shell echo -n $(VERSION) | sed -n 's/\./_/gp')
+
+ifndef PERL
+PERL=/usr/bin/perl-5.005-thread
+endif
+
+TMP=`pwd`/debian/tmp
+archlib = `$(PERL) -MConfig -e 'print $$Config{installarchlib}'`
+config = INSTALLDIRS=perl INSTALLMAN1DIR=$(TMP)/usr/man/man1 INSTALLMAN3DIR=$(TMP)/usr/man/man3 INSTALLPRIVLIB=$(TMP)/usr/lib/perl5 INSTALLARCHLIB=$(TMP)/$(archlib)
build:
$(checkdir)
- $(checkversion)
+ perl Makefile.PL $(config)
+ $(MAKE)
touch build
clean:
$(checkdir)
- $(checkversion)
-rm -f build
+ -$(MAKE) clean
-rm -f `find . -name "*~"`
-rm -rf debian/tmp debian/files* core debian/substvars
binary-indep: checkroot build
$(checkdir)
- $(checkversion)
-rm -rf debian/tmp
install -d debian/tmp
- cd debian/tmp && install -d `cat ../dirs`
- install -m 644 src/Ivy.pm debian/tmp/usr/lib/perl5
+ $(MAKE) pure_install
# Must have debmake installed for this to work. Otherwise please copy
# /usr/bin/debstd into the debian directory and change debstd to debian/debstd
- debstd doc/*.html doc/BUGS doc/NEWS doc/TODO doc/ChangeLog doc/README
- dpkg-gencontrol
- chown -R root.root debian/tmp
- chmod -R go=rX debian/tmp
+ dh_perl
+ dh_fixperms
+ debstd
+ dpkg-gencontrol -isp
dpkg --build debian/tmp ..
binary-arch: checkroot build
@@ -53,19 +57,4 @@ checkroot:
$(checkdir)
test root = "`whoami`"
-define checkversion
- -@if (test -d CVS); then \
- if (cvs status -v debian/changelog | grep --silent $(CVS_TAG)); then \
- echo "cvs tag $(CVS_TAG) matches package version $(VERSION)"; \
- else \
- echo "debian/rules: *** Warning : No cvs tag $(CVS_TAG) matches package version $(VERSION) for file changelog. You can tag your cvs module by doing debian/rules tag"; \
- echo -n "debian/rules: *** Existing tags are : "; \
- cvs status -v debian/changelog | sed -n 's/.*\(V.*_[0-9]\).*/\1/p'; \
- fi \
- fi
-endef
-
-tag:
- -@if (test -x `which cvs`); then cvs tag $(CVS_TAG) .; fi
-
.PHONY: binary binary-arch binary-indep clean checkroot