summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorfourdan2007-01-12 14:43:18 +0000
committerfourdan2007-01-12 14:43:18 +0000
commitca682fd66f1deee2fa47b0257143e2d17d322c58 (patch)
tree9aa09919a79fe8fb33a229238ed9901a1c6302ee /debian/rules
parente75120fb8c31ee4a9d21bc67ec59f2b663c36169 (diff)
downloadivy-perl-ca682fd66f1deee2fa47b0257143e2d17d322c58.zip
ivy-perl-ca682fd66f1deee2fa47b0257143e2d17d322c58.tar.gz
ivy-perl-ca682fd66f1deee2fa47b0257143e2d17d322c58.tar.bz2
ivy-perl-ca682fd66f1deee2fa47b0257143e2d17d322c58.tar.xz
Update package for Debian Etch
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules50
1 files changed, 31 insertions, 19 deletions
diff --git a/debian/rules b/debian/rules
index 4234a7a..90f7fd0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -25,30 +25,42 @@ clean:
-$(MAKE) clean
-rm -f `find . -name "*~"`
-rm -rf debian/tmp debian/files* core debian/substvars
-
-binary-indep: checkroot build
+install:
$(checkdir)
-rm -rf debian/tmp
install -d debian/tmp/usr
$(MAKE) pure_install PREFIX=$(TMP)/usr
-# Must have debmake installed for this to work. Otherwise please copy
-# /usr/bin/debstd into the debian directory and change debstd to debian/debstd
- dh_perl
- dh_fixperms
- debstd
- dpkg-gencontrol -isp
- dpkg --build debian/tmp ..
-binary-arch: checkroot build
- $(checkdir)
- $(checkversion)
-# There are no architecture-dependent files to be uploaded
-# generated by this package. If there were any they would be
-# made here.
-
-define checkdir
- test -f debian/rules
-endef
+binary-indep: build install
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_installexamples
+ dh_install --source=$(CURDIR)/debian/tmp
+# dh_installmenu
+# dh_installdebconf
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+# dh_installinit
+# dh_installcron
+# dh_installinfo
+ dh_installman
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+# dh_perl
+# dh_python
+# dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
# Below here is fairly generic really