summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authordamiano1999-03-03 15:51:58 +0000
committerdamiano1999-03-03 15:51:58 +0000
commit94c6ae74a9b3215789b1d11aaf3232b8787ce0ec (patch)
treef62006764ef661136dfbcd388e385a1c80e13329 /debian
parentdcb8fc41d02190a72e9b2b9372df7f713c0428e3 (diff)
downloadivy-perl-94c6ae74a9b3215789b1d11aaf3232b8787ce0ec.zip
ivy-perl-94c6ae74a9b3215789b1d11aaf3232b8787ce0ec.tar.gz
ivy-perl-94c6ae74a9b3215789b1d11aaf3232b8787ce0ec.tar.bz2
ivy-perl-94c6ae74a9b3215789b1d11aaf3232b8787ce0ec.tar.xz
add cvs tag checking in debian/rules
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules23
1 files changed, 22 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 19c7b48..27227a5 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,20 +3,25 @@
# based on the sample debian/rules file for GNU hello by Ian Jackson.
package=ivy-perl
+SED_COMMAND='s/.*(\([^)]*\)-.*/\1/p'
+VERSION := $(shell sed -n $(SED_COMMAND) debian/changelog | head -1)
+CVS_TAG := V$(shell echo -n $(VERSION) | sed -n 's/\./_/gp')
build:
$(checkdir)
-
+ $(checkversion)
touch build
clean:
$(checkdir)
+ $(checkversion)
-rm -f build
-rm -f `find . -name "*~"`
-rm -rf debian/tmp debian/files* core debian/substvars
binary-indep: checkroot build
$(checkdir)
+ $(checkversion)
-rm -rf debian/tmp
install -d debian/tmp
cd debian/tmp && install -d `cat ../dirs`
@@ -31,6 +36,7 @@ binary-indep: checkroot build
binary-arch: checkroot build
$(checkdir)
+ $(checkversion)
# There are no architecture-dependent files to be uploaded
# generated by this package. If there were any they would be
# made here.
@@ -47,4 +53,19 @@ checkroot:
$(checkdir)
test root = "`whoami`"
+define checkversion
+ -@if (test -d CVS); then \
+ if (cvs status -v debian/changelog | grep --silent $(CVS_TAG)); then \
+ echo "cvs tag $(CVS_TAG) matches package version $(VERSION)"; \
+ else \
+ echo "debian/rules: *** Warning : No cvs tag $(CVS_TAG) matches package version $(VERSION) for file changelog. You can tag your cvs module by doing debian/rules tag"; \
+ echo -n "debian/rules: *** Existing tags are : "; \
+ cvs status -v debian/changelog | sed -n 's/.*\(V.*_[0-9]\).*/\1/p'; \
+ fi \
+ fi
+endef
+
+tag:
+ -@if (test -x `which cvs`); then cvs tag $(CVS_TAG) .; fi
+
.PHONY: binary binary-arch binary-indep clean checkroot