summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authoretienne1998-12-14 11:21:59 +0000
committeretienne1998-12-14 11:21:59 +0000
commit9e0974547d19d633c25779529f396fd88ccef097 (patch)
treeff54b4c2358c5e81edb2a65608f880e53ba94c47 /debian
parent866586e32b0f453ec08dbc2fc25e26aeec49871e (diff)
downloadivy-perl-9e0974547d19d633c25779529f396fd88ccef097.zip
ivy-perl-9e0974547d19d633c25779529f396fd88ccef097.tar.gz
ivy-perl-9e0974547d19d633c25779529f396fd88ccef097.tar.bz2
ivy-perl-9e0974547d19d633c25779529f396fd88ccef097.tar.xz
Ajout config Debian
Diffstat (limited to 'debian')
-rw-r--r--debian/README.debian6
-rw-r--r--debian/changelog10
-rw-r--r--debian/control11
-rw-r--r--debian/copyright7
-rw-r--r--debian/files1
-rwxr-xr-xdebian/rules50
6 files changed, 85 insertions, 0 deletions
diff --git a/debian/README.debian b/debian/README.debian
new file mode 100644
index 0000000..914da39
--- /dev/null
+++ b/debian/README.debian
@@ -0,0 +1,6 @@
+ivy-perl for DEBIAN
+----------------------
+
+Comments regarding the Package
+
+Daniel Etienne <etienne@cena.dgac.fr>, Thu, 10 Dec 1998 17:20:51 +0100
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..ec7431b
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,10 @@
+ivy-perl (1.0-1) unstable; urgency=low
+
+ * Initial Release.
+
+ -- Daniel Etienne <etienne@cena.dgac.fr> Thu, 10 Dec 1998 17:20:51 +0100
+
+Local variables:
+mode: debian-changelog
+add-log-mailing-address: "etienne@cena.dgac.fr"
+End:
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..37f2d5e
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,11 @@
+Source: ivy-perl
+Section: devel
+Priority: extra
+Maintainer: Daniel Etienne <etienne@cena.dgac.fr>
+Standards-Version: 2.3.0.0
+
+Package: ivy-perl
+Architecture: any
+Depends: perl (>= 5.004), gettimeofday
+Description: Perl module and documentation for accessing the Ivy software bus
+ Perl module and documentation for accessing the Ivy software bus
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..83fca93
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,7 @@
+This package was debianized by Daniel Etienne etienne@cena.dgac.fr on
+Thu, 10 Dec 1998 17:20:51 +0100.
+
+
+Copyright:
+
+GPL
diff --git a/debian/files b/debian/files
new file mode 100644
index 0000000..b8a9a57
--- /dev/null
+++ b/debian/files
@@ -0,0 +1 @@
+ivy-perl_1.0-1_i386.deb devel extra
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..383cbb7
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,50 @@
+#!/usr/bin/make -f
+# Made with the aid of debmake, by Christoph Lameter,
+# based on the sample debian/rules file for GNU hello by Ian Jackson.
+
+package=ivy-perl
+
+build:
+ $(checkdir)
+
+ touch build
+
+clean:
+ $(checkdir)
+ -rm -f build
+ -rm -f `find . -name "*~"`
+ -rm -rf debian/tmp debian/files* core debian/substvars
+
+binary-indep: checkroot build
+ $(checkdir)
+# There are no architecture-independent files to be uploaded
+# generated by this package. If there were any they would be
+# made here.
+
+binary-arch: checkroot build
+ $(checkdir)
+ -rm -rf debian/tmp
+ install -d debian/tmp
+ cd debian/tmp && install -d `cat ../dirs`
+ cp Ivy.pm debian/tmp/usr/local/lib/site_perl
+# Must have debmake installed for this to work. Otherwise please copy
+# /usr/bin/debstd into the debian directory and change debstd to debian/debstd
+ debstd ChangeLog NEWS README TODO
+ dpkg-gencontrol
+ chown -R root.root debian/tmp
+ chmod -R go=rX debian/tmp
+ dpkg --build debian/tmp ..
+
+define checkdir
+ test -f debian/rules
+endef
+
+# Below here is fairly generic really
+
+binary: binary-indep binary-arch
+
+checkroot:
+ $(checkdir)
+ test root = "`whoami`"
+
+.PHONY: binary binary-arch binary-indep clean checkroot