summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules12
1 files changed, 8 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index ef62577..9314e97 100755
--- a/debian/rules
+++ b/debian/rules
@@ -10,12 +10,16 @@ endif
TMP=`pwd`/debian/tmp
archlib = `$(PERL) -MConfig -e 'print $$Config{installarchlib}'`
-config = INSTALLDIRS=perl INSTALLMAN1DIR=$(TMP)/usr/man/man1 INSTALLMAN3DIR=$(TMP)/usr/man/man3 INSTALLPRIVLIB=$(TMP)/usr/lib/perl5 INSTALLARCHLIB=$(TMP)$(archlib) INSTALLSCRIPT=$(TMP)/usr/bin
+#config = INSTALLDIRS=perl INSTALLMAN1DIR=$(TMP)/usr/man/man1 INSTALLMAN3DIR=$(TMP)/usr/man/man3 INSTALLPRIVLIB=$(TMP)/usr/lib/perl5 INSTALLARCHLIB=$(TMP)$(archlib) INSTALLSCRIPT=$(TMP)/usr/bin
build:
$(checkdir)
- perl Makefile.PL $(config)
+# perl Makefile.PL INSTALLDIRS=vendor
+ $(PERL) Makefile.PL INSTALLDIRS=vendor FULLPERL="PERL_DL_NONLAZY=0 /usr/bin/perl"
$(MAKE)
+# $(MAKE) OPTIMIZE="-O2 -g -Wall"
+# perl Makefile.PL $(config)
+# $(MAKE)
$(MAKE) test
touch build
@@ -29,8 +33,8 @@ clean:
binary-indep: checkroot build
$(checkdir)
-rm -rf debian/tmp
- install -d debian/tmp
- $(MAKE) pure_install
+ install -d debian/tmp/usr
+ $(MAKE) pure_install PREFIX=$(TMP)/usr
# Must have debmake installed for this to work. Otherwise please copy
# /usr/bin/debstd into the debian directory and change debstd to debian/debstd
dh_perl