summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorfourdan2007-01-15 10:12:43 +0000
committerfourdan2007-01-15 10:12:43 +0000
commit8e37ab49be1226fdf824fd61e12376b1ecc95e48 (patch)
tree5425b5f2fb59fea78f620a4ec148c079e6dcc488 /debian/rules
parentb2737297d9007ec89fb77e93c79b174066a22939 (diff)
downloadivybanner-8e37ab49be1226fdf824fd61e12376b1ecc95e48.zip
ivybanner-8e37ab49be1226fdf824fd61e12376b1ecc95e48.tar.gz
ivybanner-8e37ab49be1226fdf824fd61e12376b1ecc95e48.tar.bz2
ivybanner-8e37ab49be1226fdf824fd61e12376b1ecc95e48.tar.xz
Update package for Debian Etch
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules91
1 files changed, 57 insertions, 34 deletions
diff --git a/debian/rules b/debian/rules
index 38bd099..40edfe9 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,47 +2,68 @@
# Made with the aid of debmake, by Christoph Lameter,
# based on the sample debian/rules file for GNU hello by Ian Jackson.
+export DH_VERBOSE=1
package=ivybanner
-build:
- $(checkdir)
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+ # Add here commands to configure the package.
+ touch configure-stamp
+
+build: build-stamp
+build-stamp: configure-stamp
+ dh_testdir
+ pod2man $(package) > $(package).1
touch build
+ touch build-stamp
clean:
- $(checkdir)
- -rm -f build
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
-$(MAKE) clean
- -rm -f `find . -name "*~"`
- -rm -rf debian/tmp debian/files* core debian/substvars
+ dh_clean
-binary-indep: checkroot build
- $(checkdir)
-# There are no architecture-independent files to be uploaded
-# generated by this package. If there were any they would be
-# made here.
-
-binary-arch: checkroot build
- $(checkdir)
- -rm -rf debian/tmp
- install -d debian/tmp
- cd debian/tmp && install -d `cat ../dirs`
- install -d debian/tmp/usr/share/$(package)
- install -d debian/tmp/etc
- install -m755 $(package) debian/tmp/usr/bin/$(package)
- install -m644 $(package).conf debian/tmp/etc
- install -m644 *.gif debian/tmp/usr/share/$(package)
-# Must have debmake installed for this to work. Otherwise please copy
-# /usr/bin/debstd into the debian directory and change debstd to debian/debstd
- pod2man $(package) > $(package).1
- debstd
- dpkg-gencontrol
- chown -R root.root debian/tmp
- chmod -R go=rX debian/tmp
- dpkg --build debian/tmp ..
-
-define checkdir
- test -f debian/rules
-endef
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+ install -m755 $(package) $(CURDIR)/debian/tmp/usr/bin/$(package)
+ install -m644 $(package).conf $(CURDIR)/debian/tmp/etc
+ install -m644 *.gif $(CURDIR)/debian/tmp/usr/share/$(package)
+
+binary-indep: build install
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_installexamples
+ dh_install --source=$(CURDIR)/debian/tmp
+# dh_installmenu
+# dh_installdebconf
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+# dh_installinit
+# dh_installcron
+# dh_installinfo
+ dh_installman
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+# dh_perl
+# dh_python
+# dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
binary: binary-indep binary-arch
@@ -51,3 +72,5 @@ checkroot:
test root = "`whoami`"
.PHONY: binary binary-arch binary-indep clean checkroot
+
+