aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in26
1 files changed, 22 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 3aee97b..935640f 100644
--- a/configure.in
+++ b/configure.in
@@ -3,9 +3,9 @@ dnl # autoconf2.13 script
dnl # «»
dnl #
-AC_INIT(ivycpy.i)
+AC_INIT(src/ivycpy.i)
PACKAGE=ivycpy
-VERSION=0.6
+VERSION=2.0
MV_COLOR_ON(BLACK, WHITE)
dnl #
@@ -44,6 +44,24 @@ SWIGVERSION=`swig -version 2>&1 | grep Version | awk '{print $3}'`
MV_MSG(["SWIGVERSION is "$SWIGVERSION] , [$MAGENTA])
+dnl # checking doxygen availability and version
+
+AC_CHECK_PROGS(DOXYGEN, doxygen)
+
+if test -z "$DOXYGEN"; then
+ MV_ERROR(No Doxygen program found)
+fi
+
+DOXYGEN_VERSION=`$DOXYGEN --version`
+
+MV_MSG(You are using Doxygen version $DOXYGEN_VERSION, $CYAN)
+
+if test "$DOXYGEN_VERSION" '<' "1.4.7"; then
+ MV_ERROR(Doxygen version prior to 1.4.7 does not support python)
+fi
+
+DOCDIR=\${exec_prefix}/doc/html
+
# <check for standard thing>
# Checks for programs.
@@ -100,14 +118,14 @@ else
AC_MSG_RESULT("no")
fi
-
-
# </checking really presence of some ivycpy required header file, library>
dnl # exporting (Makefile some variables)
AC_SUBST(PACKAGE)
AC_SUBST(VERSION)
+AC_SUBST(DOXYGEN)
+AC_SUBST(DOCDIR)
AC_OUTPUT(GNUmakefile)