aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules10
1 files changed, 7 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index 33944d9..477b0bf 100755
--- a/debian/rules
+++ b/debian/rules
@@ -21,7 +21,9 @@ build-stamp:
clean:
dh_testdir
dh_testroot
- rm -f build-stamp
+ -rm -f build-stamp
+ -rm -rf debian/tmp-docs
+ -rm -rf html
# Add here commands to clean up after the build process.
-$(MAKE) distclean
@@ -36,7 +38,8 @@ install: build
# Add here commands to install the package into debian/tmp.
$(MAKE) install prefix=`pwd`/debian/tmp/usr pmode=debian
-
+ -epydoc --html -n IvyPy ivy.py
+ -epydoc --pdf -n IvyPy -o debian/tmp-docs ivy.py
# Build architecture-independent files here.
binary-indep: build install
@@ -48,7 +51,8 @@ binary-arch: build install
dh_testdir
dh_testroot
# dh_installdebconf
- dh_installdocs
+ dh_installdocs
+ dh_installdocs -i debian/tmp-docs/api.pdf html
# dh_installexamples examples/* _dp
dh_installmenu
# dh_installemacsen