summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authoretienne2003-05-07 13:18:53 +0000
committeretienne2003-05-07 13:18:53 +0000
commit06fcc08f222a7753b431269737f8eec58bb9de54 (patch)
treec87afc5959329492f5bfb8300222b0407f01f70c /debian/rules
parent81840b81a53b005f344d6809be287026577a8928 (diff)
downloadivylaunch-06fcc08f222a7753b431269737f8eec58bb9de54.zip
ivylaunch-06fcc08f222a7753b431269737f8eec58bb9de54.tar.gz
ivylaunch-06fcc08f222a7753b431269737f8eec58bb9de54.tar.bz2
ivylaunch-06fcc08f222a7753b431269737f8eec58bb9de54.tar.xz
*** empty log message ***
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules51
1 files changed, 51 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..ceb2ad8
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,51 @@
+#!/usr/bin/make -f
+# Made with the aid of debmake, by Christoph Lameter,
+# based on the sample debian/rules file for GNU hello by Ian Jackson.
+
+package=ivylaunch
+
+build:
+ $(checkdir)
+ touch build
+
+clean:
+ $(checkdir)
+ -rm -f build
+ -$(MAKE) clean
+ -rm -f `find . -name "*~"`
+ -rm -rf debian/tmp debian/files* core debian/substvars
+
+binary-indep: checkroot build
+ $(checkdir)
+# There are no architecture-independent files to be uploaded
+# generated by this package. If there were any they would be
+# made here.
+
+binary-arch: checkroot build
+ $(checkdir)
+ -rm -rf debian/tmp
+ install -d debian/tmp
+ cd debian/tmp && install -d `cat ../dirs`
+ install -d debian/tmp/usr/lib/$(package)
+ install -m755 ivylaunch debian/tmp/usr/bin/ivylaunch
+ install -m644 FugueConfig.pm debian/tmp/usr/lib/ivylaunch/FugueConfig.pm
+# Must have debmake installed for this to work. Otherwise please copy
+# /usr/bin/debstd into the debian directory and change debstd to debian/debstd
+ pod2man ivylaunch > ivylaunch.1
+ debstd
+ dpkg-gencontrol
+ chown -R root.root debian/tmp
+ chmod -R go=rX debian/tmp
+ dpkg --build debian/tmp ..
+
+define checkdir
+ test -f debian/rules
+endef
+
+binary: binary-indep binary-arch
+
+checkroot:
+ $(checkdir)
+ test root = "`whoami`"
+
+.PHONY: binary binary-arch binary-indep clean checkroot