aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/README4
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control13
-rw-r--r--debian/dirs2
-rw-r--r--debian/ivypointer.dirs2
-rw-r--r--debian/ivypointer.install2
-rwxr-xr-xdebian/rules71
-rw-r--r--debian/substvars1
9 files changed, 101 insertions, 0 deletions
diff --git a/debian/README b/debian/README
new file mode 100644
index 0000000..47246b1
--- /dev/null
+++ b/debian/README
@@ -0,0 +1,4 @@
+
+Construction de ivypointer :
+
+ - Il faut installer au préalable les paquetages automake et autoconf.
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..a1b2056
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+ivypointer (0.0.1-0) unstable; urgency=low
+
+ * Initial release
+
+ -- Benjamin Tissoires <tissoire@cena.fr> Thu, 20 Dec 2007 12:50:00 +0100
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..b8626c4
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+4
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..97c7d34
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,13 @@
+Source: ivypointer
+Priority: extra
+Section: unknown
+Maintainer: Benjamin Tissoires <tissoire@cena.fr>
+Build-Depends: debhelper (>> 4.0.0), libc6-dev, xlibs-dev | libx11-dev | xorg-dev, ivy-c-dev
+Standards-Version: 0.0.1
+
+Package: ivypointer
+Section: unknown
+Architecture: any
+Depends: ${shlibs:Depends}
+Description: Ivypointer, control your mouse through Ivy
+
diff --git a/debian/dirs b/debian/dirs
new file mode 100644
index 0000000..c73a7eb
--- /dev/null
+++ b/debian/dirs
@@ -0,0 +1,2 @@
+usr/bin
+usr/man/man1
diff --git a/debian/ivypointer.dirs b/debian/ivypointer.dirs
new file mode 100644
index 0000000..c73a7eb
--- /dev/null
+++ b/debian/ivypointer.dirs
@@ -0,0 +1,2 @@
+usr/bin
+usr/man/man1
diff --git a/debian/ivypointer.install b/debian/ivypointer.install
new file mode 100644
index 0000000..5fe3a91
--- /dev/null
+++ b/debian/ivypointer.install
@@ -0,0 +1,2 @@
+usr/bin/*
+usr/man/man1/*
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..d587e2a
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,71 @@
+#!/usr/bin/make -f
+# Made with the aid of debmake, by Christoph Lameter,
+# based on the sample debian/rules file for GNU hello by Ian Jackson.
+
+# Uncomment this to turn on verbose mode.
+export DH_VERBOSE=1
+
+SED_COMMAND='s/.*(\([^)]*\)).*/\1/p'
+MAJOR := $(shell sed -n $(SED_COMMAND) debian/changelog | head -1 | sed -n 's/\([0-9]*\)\..*/\1/p')
+MINOR := $(shell sed -n $(SED_COMMAND) debian/changelog | head -1 | sed -n 's/[0-9]*\.\([0-9\.]*\).*/\1/p')
+
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+ # Add here commands to configure the package.
+ ./configure --prefix=/usr
+ touch configure-stamp
+
+build: build-stamp
+build-stamp: configure-stamp
+ dh_testdir
+ $(MAKE) all MAJOR=$(MAJOR) MINOR=$(MINOR)
+ touch build-stamp
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+ $(MAKE) clean
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+ $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
+
+binary-indep: build install
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_installexamples
+ dh_install --source=$(CURDIR)/debian/tmp
+# dh_installmenu
+# dh_installdebconf
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+# dh_installinit
+# dh_installcron
+# dh_installinfo
+ dh_installman
+ dh_link
+# dh_strip
+ dh_compress
+ dh_fixperms
+# dh_perl
+# dh_python
+# dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure
diff --git a/debian/substvars b/debian/substvars
new file mode 100644
index 0000000..387115a
--- /dev/null
+++ b/debian/substvars
@@ -0,0 +1 @@
+shlibs:Depends=libc6 (>= 2.3.2.ds1-21), libglib2.0-0 (>= 2.6.0), libice6, libpcre3 (>= 4.5), libsm6, libx11-6, libxt6, ivy-c