summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules87
1 files changed, 55 insertions, 32 deletions
diff --git a/debian/rules b/debian/rules
index 88c103f..77c1b01 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,45 +2,68 @@
# Made with the aid of debmake, by Christoph Lameter,
# based on the sample debian/rules file for GNU hello by Ian Jackson.
+export DH_VERBOSE=1
package=transduct
-build:
- $(checkdir)
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+ # Add here commands to configure the package.
+ touch configure-stamp
+
+build: build-stamp
+build-stamp: configure-stamp
+ dh_testdir
+# perl Makefile.PL INSTALLDIRS=perl
+# $(MAKE)
+# $(MAKE) test
touch build
+ touch build-stamp
clean:
- $(checkdir)
- -rm -f build
- -rm -f `find . -name "*~"`
- -rm -rf debian/tmp debian/files* core debian/substvars
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+ -$(MAKE) clean
+ dh_clean
-binary-indep: checkroot build
- $(checkdir)
-# There are no architecture-independent files to be uploaded
-# generated by this package. If there were any they would be
-# made here.
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+ install -m755 src/$(package) $(CURDIR)/debian/tmp/usr/bin/$(package)
-binary-arch: checkroot build
- $(checkdir)
- -rm -rf debian/tmp
- install -d debian/tmp
- cd debian/tmp && install -d `cat ../dirs`
- install -d debian/tmp/usr/lib/$(package)
- install -m755 src/transduct debian/tmp/usr/bin/$(package)
- install -m644 src/*.pm data/*.gif debian/tmp/usr/lib/$(package)
- install -d debian/tmp/usr/share/man/man1
- pod2man src/$(package) > debian/tmp/usr/share/man/man1/$(package).1
-# Must have debmake installed for this to work. Otherwise please copy
-# /usr/bin/debstd into the debian directory and change debstd to debian/debstd
- debstd -c -d
- dpkg-gencontrol
- chown -R root.root debian/tmp
- chmod -R go=rX debian/tmp
- dpkg --build debian/tmp ..
-
-define checkdir
- test -f debian/rules
-endef
+binary-indep: build install
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+# dh_installexamples
+ dh_install --source=$(CURDIR)/debian/tmp
+# dh_installmenu
+# dh_installdebconf
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+# dh_installinit
+# dh_installcron
+# dh_installinfo
+ dh_installman
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+# dh_perl
+# dh_python
+# dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
# Below here is fairly generic really