summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorguez2008-04-08 13:43:01 +0000
committerguez2008-04-08 13:43:01 +0000
commit8f1e0435cca1d97caba2da1e306432ace45d0bbd (patch)
tree55a65c1ccd8c1f8401f6bb204b656f451fcf97e8 /debian
downloadxinput-ivy-8f1e0435cca1d97caba2da1e306432ace45d0bbd.zip
xinput-ivy-8f1e0435cca1d97caba2da1e306432ace45d0bbd.tar.gz
xinput-ivy-8f1e0435cca1d97caba2da1e306432ace45d0bbd.tar.bz2
xinput-ivy-8f1e0435cca1d97caba2da1e306432ace45d0bbd.tar.xz
Version 1.1 de xinput-ivy, auteur Philippe Ribet
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog16
-rw-r--r--debian/compat1
-rw-r--r--debian/control15
-rw-r--r--debian/copyright10
-rw-r--r--debian/dirs1
-rw-r--r--debian/docs0
-rw-r--r--debian/install1
-rwxr-xr-xdebian/rules73
8 files changed, 117 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..c621b15
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,16 @@
+xinput-ivy (1.1-1) unstable; urgency=low
+
+ * Ajout de l'information hires (précision subpixel de la position du
+ pointeur).
+ * Ajout de l'information de proximité
+ * Les deux sliders sont maintenant réinitialisés à 0 lorsque le doigt
+ est enlevé.
+ * Les boutons des stylets sont reportés dans les messages.
+
+ -- Philippe Ribet <ribet@cena.fr> Fri, 28 Mar 2008 16:46:00 +0100
+
+xinput-ivy (1.0-1) unstable; urgency=low
+
+ * Initial Debian release
+
+ -- Olivier Fourdan <fourdan@cena.fr> Mon, 5 Mar 2007 15:22:41 +0100
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..b8626c4
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+4
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..952dbf8
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,15 @@
+Source: xinput-ivy
+Priority: optional
+Maintainer: Philippe Ribet <ribet@cena.fr>
+Build-Depends: debhelper (>= 4.0.0), xlibs-dev | libx11-dev, ivy-c-dev (>=3.9), libxi-dev | x11proto-input-dev
+Standards-Version: 3.6.1
+Section: tools
+
+Package: xinput-ivy
+Section: x11
+Architecture: any
+Depends: ${misc:Depends}, ivy-c (>=3.9), libxi6
+Description: Ivy proxy for XInput
+ "xinput_ivy" acts as an Ivy proxy, receiving XInput events and
+ broadcasting corresponding Ivy messages.
+ Useful with Wacom Cintiq 21UX.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..869b712
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,10 @@
+This package was debianized by Olivier Fourdan <fourdan@cena.fr> on
+Mon, 5 Mar 2007 15:22:41 +0100.
+
+Author: Philippe Ribet <ribet@cena.fr>
+
+Copyright Holder: CENA
+
+License:
+
+GPL
diff --git a/debian/dirs b/debian/dirs
new file mode 100644
index 0000000..e772481
--- /dev/null
+++ b/debian/dirs
@@ -0,0 +1 @@
+usr/bin
diff --git a/debian/docs b/debian/docs
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/debian/docs
diff --git a/debian/install b/debian/install
new file mode 100644
index 0000000..1df36c6
--- /dev/null
+++ b/debian/install
@@ -0,0 +1 @@
+usr/bin/*
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..52d6898
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,73 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+#
+# $Id$
+#
+
+package=xinput-ivy
+
+# Uncomment this to turn on verbose mode.
+export DH_VERBOSE=1
+
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+ touch configure-stamp
+
+build: build-stamp
+build-stamp: configure-stamp
+ dh_testdir
+ touch build-stamp
+ $(MAKE) DESTDIR=$(CURDIR)/debian/tmp PREFIX=/usr
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+ $(MAKE) clean
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+ $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp PREFIX=/usr
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+# dh_installdocs README
+ dh_installexamples
+ dh_install --source=$(CURDIR)/debian/tmp
+# dh_installmenu
+# dh_installdebconf
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+# dh_installinit
+# dh_installcron
+# dh_installinfo
+ dh_installman
+ dh_link
+ dh_strip
+# dh_compress
+# dh_fixperms
+# dh_perl
+# dh_python
+# dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure