aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorlecoanet2004-03-24 15:12:40 +0000
committerlecoanet2004-03-24 15:12:40 +0000
commitc5ffe14f3a69402458d5c954b9abb440d71db568 (patch)
tree35e743f31885e55eaf9b8d6356fc7e87457136d1 /debian
parent0bd873e76d332f4a9caa76b9b2eca523d3a84055 (diff)
downloadtkzinc-c5ffe14f3a69402458d5c954b9abb440d71db568.zip
tkzinc-c5ffe14f3a69402458d5c954b9abb440d71db568.tar.gz
tkzinc-c5ffe14f3a69402458d5c954b9abb440d71db568.tar.bz2
tkzinc-c5ffe14f3a69402458d5c954b9abb440d71db568.tar.xz
*** empty log message ***
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog42
1 files changed, 37 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index 2eeeaf8..c9add61 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,41 @@
zinc-tk (3.2.97) unstable; urgency=low
+ * Added a tget command. If called with a transform or an
+ item as parameter, it returns the transform factors as
+ a list (compatible with tset). An optional second parameter
+ can be given, either 'all' meaning decompose the transform
+ in translation, scale, rotation, skew and return the list
+ in this order, or 'translation', 'scale', 'rotation', 'skew'
+ which means return the corresponding value.
+ * Added an optional boolean parameter abs to the translate
+ command. If true it means that the translation should be
+ interpreted as absolute. If absent or false the usual
+ behavior is preserved.
+ * Under OpenGL, a single graphic context is used for all
+ zincs on a single display. Textures are put in common
+ for the display. This should greatly reduce the resource
+ consumption with GL.
+ * Potential memory bugs have been fixed thanks to valgrind.
+ * The code can be compiled either for perl/Tk 800 (define
+ PTK and PTK_800) or perl/Tk 804 (define PTK alone).
+ * The coords command returns a flat point instead of a list
+ of one point for all items with a -position attribute.
+ * The transformation of items with a -position has been slightly
+ modified. The point described by -position is no longer considered
+ in the coordinate space of the item but in the coordinate space
+ of its parent group. The item is always located in 0,0 of its
+ own coordinate space. This is so to make use of -composescale and
+ -composerotation a lot more useful (and compatible).
+ * The default value of -composescale and -composerotation on texts
+ and icons is now false. This is coherent with the default behavior
+ of these items (being rigids). The impact of this change is
+ greatly minored by the new processing of the -position attribute.
+ * Modified the command bindings for the transform
+ testbed demo. Added a new delete item command.
+ * Added two new Tcl demos ported from perl, testGraphics
+ and magicLens.
+ * Ported the Graphics package by JL Vinot to Tcl as
+ zincGraphics.
* Modified the behavior of options and arguments controlling
the display of track history. The -trackmanagehistory is
gone, a -trackvisiblehistorysize option has appeared, it
@@ -13,12 +49,8 @@ zinc-tk (3.2.97) unstable; urgency=low
to render OpenGL strings in all configurations.
* Fixed a bug in indexing a Text item with utf8 characters
(above 127).
- * Fixed a clamping problem in the -visiblehistorysize
- Track attribute, preventing a track to display its
- history after a reset of the -managedhistorysize option.
* Re-ported the pathtag demo from Perl to Tcl.
* Fixed some bugs in the transform code (core dumps)
- * Significant reduction in size of many items.
* The scale method takes an optional center
* The angle in the rotate method can be specified in
degrees, a flag has been added to tell if the angle
@@ -39,7 +71,7 @@ zinc-tk (3.2.97) unstable; urgency=low
* The bind method now handles virtual events (an omission).
* The bind method accept an alternative syntax for specifying
bindings on fields instead of saying:
- .z bind $id:3 <1> "script"
+ .z bind $id:3 <1> "script"
it is possible to say:
.z bind $id 3 <1> "script"
This is coherent with the syntax used by the other methods.