aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index c8a1ebb..0ce64dd 100644
--- a/configure.in
+++ b/configure.in
@@ -45,13 +45,16 @@ TEA_INIT
# PATCHLEVEL. The windows variant does not containt a dot.
#-----------------------------------------------------------------------
MAJOR_VERSION=3
-
MINOR_VERSION=3
PATCHLEVEL=0
VERSION=${MAJOR_VERSION}.${MINOR_VERSION}.${PATCHLEVEL}
+AC_SUBST(MAJOR_VERSION)
+AC_SUBST(MINOR_VERSION)
+AC_SUBST(PATCHLEVEL)
AC_SUBST(VERSION)
+AC_SUBST(WIN_VERSION)
AC_SUBST(PACKAGE)
AC_SUBST(Tkzinc_LIB_FILE)
AC_SUBST(Tkzincstub_LIB_FILE)
@@ -231,4 +234,4 @@ ZINC_ENABLE_OM
AC_SUBST(aux_BINARIES)
AC_SUBST(bin_BINARIES)
-AC_OUTPUT([Makefile Python/Zinc.py])
+AC_OUTPUT([Makefile starkit.tcl Perl/Makefile.PL Perl/Zinc.pm Python/Zinc.py win/makefile.vc win/Tkzinc.aip win/Tkzincperl.aip])