aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorThéo de la Hogue2023-03-13 15:58:03 +0100
committerThéo de la Hogue2023-03-13 15:58:03 +0100
commit67405a9de1f50a1ae2d05485af7ca9a365029035 (patch)
tree8beac41612ba178afafd729d5eb7b0668e9a65a5 /setup.py
parentddd417ca84c5e16ba30c441598d209d190bf4ad3 (diff)
downloadargaze-67405a9de1f50a1ae2d05485af7ca9a365029035.zip
argaze-67405a9de1f50a1ae2d05485af7ca9a365029035.tar.gz
argaze-67405a9de1f50a1ae2d05485af7ca9a365029035.tar.bz2
argaze-67405a9de1f50a1ae2d05485af7ca9a365029035.tar.xz
Updating library to work with Python 3.11 and OpenCV 4.7.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index e7ac240..01072f9 100644
--- a/setup.py
+++ b/setup.py
@@ -34,8 +34,8 @@ setup(
package_dir={'':'src'},
packages=find_packages(where='src'),
- python_requires='>=3.6, <4',
- install_requires=['opencv-python==4.6.0.66', 'opencv-contrib-python==4.6.0.66', 'numpy', 'av', 'rtsp', 'netifaces', 'pandas', 'matplotlib', 'shapely'],
+ python_requires='>=3.11',
+ install_requires=['opencv-python>=4.7.0', 'opencv-contrib-python>=4.7.0', 'numpy', 'av', 'rtsp', 'netifaces', 'pandas', 'matplotlib', 'shapely', 'scipy'],
project_urls={
'Bug Reports': 'https://git.recherche.enac.fr/projects/argaze/issues',