aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index e7ac240..01072f9 100644
--- a/setup.py
+++ b/setup.py
@@ -34,8 +34,8 @@ setup(
package_dir={'':'src'},
packages=find_packages(where='src'),
- python_requires='>=3.6, <4',
- install_requires=['opencv-python==4.6.0.66', 'opencv-contrib-python==4.6.0.66', 'numpy', 'av', 'rtsp', 'netifaces', 'pandas', 'matplotlib', 'shapely'],
+ python_requires='>=3.11',
+ install_requires=['opencv-python>=4.7.0', 'opencv-contrib-python>=4.7.0', 'numpy', 'av', 'rtsp', 'netifaces', 'pandas', 'matplotlib', 'shapely', 'scipy'],
project_urls={
'Bug Reports': 'https://git.recherche.enac.fr/projects/argaze/issues',