aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml13
1 files changed, 8 insertions, 5 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 383e156..3904a2f 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,12 +1,12 @@
[build-system]
requires = [
- "setuptools"
+ "setuptools",
+ "setuptools-scm"
]
build-backend = "setuptools.build_meta"
[project]
name = "argaze"
-version = "0.0.7"
authors = [
{"name" = "ACHIL laboratory at Ecole Nationale de l'Aviation Civile (ENAC)", "email" = "argaze-contact@recherche.enac.fr"}
]
@@ -21,7 +21,7 @@ keywords=[
]
license = {file = "LICENSE"}
classifiers=[
- "Development Status :: 3 - Alpha",
+ "Development Status :: 5 - Production/Stable",
"Intended Audience :: Developers",
"Intended Audience :: Science/Research",
"Topic :: Scientific/Engineering :: Human Machine Interfaces",
@@ -30,8 +30,8 @@ classifiers=[
"Operating System :: OS Independent"
]
dependencies = [
- "opencv-python>=4.7.0",
- "opencv-contrib-python>=4.7.0",
+ "opencv-python>=4.10.0",
+ "opencv-contrib-python>=4.10.0",
"numpy",
"pandas",
"av",
@@ -42,6 +42,7 @@ dependencies = [
"scipy",
"scikit-learn"
]
+dynamic = ["version"]
[project.urls]
Homepage = "https://gitpub.recherche.enac.fr/argaze"
@@ -51,3 +52,5 @@ Issues = "https://git.recherche.enac.fr/projects/argaze/issues"
[tool.setuptools]
package-dir = {"" = "src"}
+
+[tool.setuptools_scm]