summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorlecoanet1998-12-11 17:24:48 +0000
committerlecoanet1998-12-11 17:24:48 +0000
commit25c512868d7948bc02ba91e9f06d398c31b0bedf (patch)
treedef6b2544cf3c81068bac6788f4ab9465de236b7 /debian/rules
parent34ace791502635f9bc725192bc609994e9f9b730 (diff)
downloadivy-c-25c512868d7948bc02ba91e9f06d398c31b0bedf.zip
ivy-c-25c512868d7948bc02ba91e9f06d398c31b0bedf.tar.gz
ivy-c-25c512868d7948bc02ba91e9f06d398c31b0bedf.tar.bz2
ivy-c-25c512868d7948bc02ba91e9f06d398c31b0bedf.tar.xz
Modification pour debianisation
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules58
1 files changed, 58 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..00dfae6
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,58 @@
+#!/usr/bin/make -f
+# Made with the aid of debmake, by Christoph Lameter,
+# based on the sample debian/rules file for GNU hello by Ian Jackson.
+
+package=ivy-c
+
+version=$(shell expr `pwd` : '.*-\([0-9.]*\)')
+version_major=$(shell expr `pwd` : '.*-\([0-9]*\).[0-9.]*')
+
+build:
+ $(checkdir)
+
+ cd src && make all
+
+ touch build
+
+clean:
+ $(checkdir)
+ -rm -f build
+
+ -rm -rf debian/tmp `find debian/* -type d ! -name CVS` debian/files* core
+ -rm -f debian/*substvars
+
+binary-indep: checkroot build
+ $(checkdir)
+# There are no architecture-independent files to be uploaded
+# generated by this package. If there were any they would be
+# made here.
+
+binary-arch: checkroot build
+ $(checkdir)
+ -rm -rf debian/tmp `find debian/* -type d`
+ install -d debian/tmp
+ cd debian/tmp && install -d `cat ../dirs`
+
+ cd src && make install DESTDIR=`pwd`/../debian/tmp
+
+ debstd
+ -rmdir debian/tmp/usr/include
+
+ dpkg-gencontrol -p$(package)
+ chown -R root.root debian/tmp
+ chmod -R go=rX debian/tmp
+ dpkg --build debian/tmp ..
+
+define checkdir
+ test -f debian/rules
+endef
+
+# Below here is fairly generic really
+
+binary: binary-indep binary-arch
+
+checkroot:
+ $(checkdir)
+ test root = "`whoami`"
+
+.PHONY: binary binary-arch binary-indep clean checkroot