summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authordamiano1998-12-28 15:48:35 +0000
committerdamiano1998-12-28 15:48:35 +0000
commitc32508e67bb56fb59c85e7fe298610656756b393 (patch)
treef6f2fb7312e0ef17614f9c47636322395582e558 /debian/rules
parentff5b5d047fc3e237ad49e0673ee30d380505d511 (diff)
downloadivy-c-c32508e67bb56fb59c85e7fe298610656756b393.zip
ivy-c-c32508e67bb56fb59c85e7fe298610656756b393.tar.gz
ivy-c-c32508e67bb56fb59c85e7fe298610656756b393.tar.bz2
ivy-c-c32508e67bb56fb59c85e7fe298610656756b393.tar.xz
Correction de debian/rules et src/Makefile
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 4 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index 6b5213a..f687d25 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,10 +4,9 @@
package=ivy-c
-SED_COMMAND_VERSION='s/.*(\([^)]*\)).*/\1/p'
-VERSION := $(shell sed -n $(SED_COMMAND_VERSION) debian/changelog | head -1 | sed -n 's/\([0-9]*\)\..*/\1/p')
-SED_COMMAND_MAJOR_MINOR='s/.*(\([^)]*\)).*/\1/p'
-MAJOR_MINOR := $(shell sed -n $(SED_COMMAND_MAJOR_MINOR) debian/changelog | head -1 | sed -n 's/[0-9]*\.\([0-9\.]*\).*/\1/p')
+SED_COMMAND='s/.*(\([^)]*\)).*/\1/p'
+MAJOR := $(shell sed -n $(SED_COMMAND) debian/changelog | head -1 | sed -n 's/\([0-9]*\)\..*/\1/p')
+MINOR := $(shell sed -n $(SED_COMMAND) debian/changelog | head -1 | sed -n 's/[0-9]*\.\([0-9\.]*\).*/\1/p')
build:
$(checkdir)
@@ -35,7 +34,7 @@ binary-arch: checkroot build
install -d debian/tmp
cd debian/tmp && install -d `cat ../dirs`
- cd src && make install DESTDIR=`pwd`/../debian/tmp VERSION=$(VERSION) MAJOR_MINOR=$(MAJOR_MINOR)
+ cd src && make install DESTDIR=`pwd`/../debian/tmp MAJOR=$(MAJOR) MINOR=$(MINOR)
debstd
-rmdir debian/tmp/usr/include