summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules124
1 files changed, 58 insertions, 66 deletions
diff --git a/debian/rules b/debian/rules
index e78e6a8..53bb2f6 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,77 +2,69 @@
# Made with the aid of debmake, by Christoph Lameter,
# based on the sample debian/rules file for GNU hello by Ian Jackson.
+# Uncomment this to turn on verbose mode.
+export DH_VERBOSE=1
+
SED_COMMAND='s/.*(\([^)]*\)).*/\1/p'
MAJOR := $(shell sed -n $(SED_COMMAND) debian/changelog | head -1 | sed -n 's/\([0-9]*\)\..*/\1/p')
MINOR := $(shell sed -n $(SED_COMMAND) debian/changelog | head -1 | sed -n 's/[0-9]*\.\([0-9\.]*\).*/\1/p')
-package=ivy-c
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+ # Add here commands to configure the package.
+ touch configure-stamp
-build:
- $(checkdir)
- cd src && make all MAJOR=$(MAJOR) MINOR=$(MINOR) TCLINC=$(-I/usr/include/tcl8.3/) TCLLIB=$(-ltcl8.3) CFLAGS="-g -fPIC -D_REENTRANT"
- touch build
+build: build-stamp
+build-stamp: configure-stamp
+ dh_testdir
+ cd src && $(MAKE) all MAJOR=$(MAJOR) MINOR=$(MINOR) TCLINC=$(-I/usr/include/tcl8.3/) TCLLIB=$(-ltcl8.3) CFLAGS="-g -fPIC -D_REENTRANT"
+ touch build-stamp
clean:
- $(checkdir)
- -rm -f build
- -rm -rf debian/tmp debian/*~ debian/copyright `find debian/* -type d ! -name CVS` debian/files* core
- -rm -f debian/*substvars
- cd src && make clean
-
-binary-indep: checkroot build
- $(checkdir)
-# There are no architecture-independent files to be uploaded
-# generated by this package. If there were any they would be
-# made here.
-
-binary-arch: checkroot build
- $(checkdir)
- -rm -rf debian/tmp `find debian/* -type d ! -name CVS`
- install -d debian/tmp
- cd debian/tmp && install -d `cat ../dirs`
-
- cd src && make installlibs PREFIX=`pwd`/../debian/tmp MAJOR=$(MAJOR) MINOR=$(MINOR)
- cd src && make installbins PREFIX=`pwd`/../debian/tmp
- cd src && make installdocs PREFIX=`pwd`/../debian/tmp
-
- -rm debian/tmp/usr/include/list.h # it's yet in utils-c-dev
- -cp src/version.h debian/copyright
- #dh_strip debian/tmp/usr/lib/libivy.so.$(MAJOR).$(MINOR)
- strip debian/tmp/usr/lib/libivy.so.$(MAJOR).$(MINOR)
- #dh_strip debian/tmp/usr/lib/libtclivy.so.$(MAJOR).$(MINOR)
- strip debian/tmp/usr/lib/libtclivy.so.$(MAJOR).$(MINOR)
- #dh_strip debian/tmp/usr/X11R6/lib/libxtivy.so.$(MAJOR).$(MINOR)
- strip debian/tmp/usr/X11R6/lib/libxtivy.so.$(MAJOR).$(MINOR)
-
- dh_link usr/lib/libivy.so.$(MAJOR).$(MINOR) usr/lib/libivy.so.$(MAJOR)
- dh_link usr/lib/libgivy.so.$(MAJOR).$(MINOR) usr/lib/libgivy.so.$(MAJOR)
- dh_link usr/lib/libtclivy.so.$(MAJOR).$(MINOR) usr/lib/libtclivy.so.$(MAJOR)
- dh_link usr/X11R6/lib/libxtivy.so.$(MAJOR).$(MINOR) usr/X11R6/lib/libxtivy.so.$(MAJOR)
- dh_link usr/lib/libivy.so.$(MAJOR).$(MINOR) usr/lib/libivy.so
- dh_link usr/lib/libgivy.so.$(MAJOR).$(MINOR) usr/lib/libgivy.so
- dh_link usr/lib/libtclivy.so.$(MAJOR).$(MINOR) usr/lib/libtclivy.so
- dh_link usr/X11R6/lib/libxtivy.so.$(MAJOR).$(MINOR) usr/X11R6/lib/libxtivy.so
-
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+ cd src && $(MAKE) clean
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+ cd src && $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
+
+binary-indep: build install
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_installexamples
+ dh_install --source=$(CURDIR)/debian/tmp
+# dh_installmenu
+# dh_installdebconf
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+# dh_installinit
+# dh_installcron
+# dh_installinfo
+ dh_installman
+ dh_link
+ dh_strip
+ dh_compress
dh_fixperms
-
- debstd doc/man-ivy-c.html doc/ivy-c-*.html
-
- -rmdir debian/tmp/usr/include
-
- dpkg-gencontrol -p$(package) -isp
- dpkg --build debian/tmp ..
-
-define checkdir
- test -f debian/rules
-endef
-
-# Below here is fairly generic really
-
-binary: binary-indep binary-arch
-
-checkroot:
- $(checkdir)
- test root = "`whoami`"
-
-.PHONY: binary binary-arch binary-indep clean checkroot
+# dh_perl
+# dh_python
+# dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure