summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/compat1
-rw-r--r--debian/control27
-rw-r--r--debian/dirs7
-rw-r--r--debian/ivy-c-dev.dirs2
-rw-r--r--debian/ivy-c-dev.files9
-rw-r--r--debian/ivy-c-dev.install8
-rw-r--r--debian/ivy-c.dirs4
-rw-r--r--debian/ivy-c.install4
-rwxr-xr-xdebian/rules124
-rw-r--r--debian/substvars1
10 files changed, 95 insertions, 92 deletions
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..b8626c4
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+4
diff --git a/debian/control b/debian/control
index 7f3e616..d334307 100644
--- a/debian/control
+++ b/debian/control
@@ -1,26 +1,29 @@
Source: ivy-c
-Section: devel
Priority: extra
+Section: devel
Maintainer: Yannick Jestin <jestin@cena.fr>
-Standards-Version: 3.1.1.1
+Build-Depends: debhelper (>> 4.0.0)
+Standards-Version: 3.6.1
-Package: ivy-c
+Package: ivy-c-dev
+Section: libdevel
Architecture: any
-Depends: ${shlibs:Depends}
-Build-Depends: debhelper, libc6-dev, xlibs-dev, tcl8.4-dev, libgtk1.2-dev, libpcre3-dev
+Depends: ivy-c (= ${Source-Version}), libc6-dev, xlibs-dev, libgtk1.2-dev
Suggests: tclsh, wish
-Conflicts: ivy-tcl
-Description: Ivy software bus. runtime Package
+Description: Ivy software bus. development Package
+ This package is needed for compiling applications using ivy-c.
Ivy is mostly a communication convention between processes, implemented
- through a collection of libraries in several languages and for several platforms:
+ through a collection of libraries in several languages and for several platforms,
from C to Perl, from Macintosh or WindowsNT to Linux or Unix.
-Package: ivy-c-dev
+Package: ivy-c
+Section: libs
Architecture: any
-Depends: ivy-c (>= 3.2-3), libc6-dev, xlibs-dev, libgtk1.2-dev
+Depends: ${shlibs:Depends}
+Build-Depends: debhelper, libc6-dev, xlibs-dev, tcl8.4-dev, libgtk1.2-dev, libpcre3-dev
Suggests: tclsh, wish
-Description: Ivy software bus. development Package
- This package is needed for compiling applications using ivy-c.
+Conflicts: ivy-tcl
+Description: Ivy software bus. runtime Package
Ivy is mostly a communication convention between processes, implemented
through a collection of libraries in several languages and for several platforms:
from C to Perl, from Macintosh or WindowsNT to Linux or Unix.
diff --git a/debian/dirs b/debian/dirs
index e09a7e3..6593239 100644
--- a/debian/dirs
+++ b/debian/dirs
@@ -1,7 +1,4 @@
-usr/man/man1
+usr/X11R6/lib
usr/lib
usr/bin
-usr/X11R6/lib
-usr/X11R6/bin
-usr/include
-usr/man/man3
+usr/man/man1
diff --git a/debian/ivy-c-dev.dirs b/debian/ivy-c-dev.dirs
new file mode 100644
index 0000000..4cfc12a
--- /dev/null
+++ b/debian/ivy-c-dev.dirs
@@ -0,0 +1,2 @@
+usr/X11R6/lib
+usr/lib
diff --git a/debian/ivy-c-dev.files b/debian/ivy-c-dev.files
deleted file mode 100644
index 73fa322..0000000
--- a/debian/ivy-c-dev.files
+++ /dev/null
@@ -1,9 +0,0 @@
-usr/include
-usr/lib/libivy.a
-usr/lib/libivy.so
-usr/lib/libgivy.a
-usr/lib/libgivy.so
-usr/lib/libtclivy.a
-usr/lib/libtclivy.so
-usr/X11R6/lib/libxtivy.a
-usr/X11R6/lib/libxtivy.so
diff --git a/debian/ivy-c-dev.install b/debian/ivy-c-dev.install
new file mode 100644
index 0000000..d73b978
--- /dev/null
+++ b/debian/ivy-c-dev.install
@@ -0,0 +1,8 @@
+usr/lib/*.so
+usr/lib/*.a
+usr/lib/*.la
+usr/X11R6/lib/*.so
+usr/X11R6/lib/*.a
+usr/X11R6/lib/*.la
+usr/include/Ivy/*.h
+usr/lib/pkgconfig/*
diff --git a/debian/ivy-c.dirs b/debian/ivy-c.dirs
new file mode 100644
index 0000000..6593239
--- /dev/null
+++ b/debian/ivy-c.dirs
@@ -0,0 +1,4 @@
+usr/X11R6/lib
+usr/lib
+usr/bin
+usr/man/man1
diff --git a/debian/ivy-c.install b/debian/ivy-c.install
new file mode 100644
index 0000000..38010b3
--- /dev/null
+++ b/debian/ivy-c.install
@@ -0,0 +1,4 @@
+usr/X11R6/lib/*.so.*
+usr/lib/*.so.*
+usr/bin/*
+usr/man/man1/*
diff --git a/debian/rules b/debian/rules
index e78e6a8..53bb2f6 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,77 +2,69 @@
# Made with the aid of debmake, by Christoph Lameter,
# based on the sample debian/rules file for GNU hello by Ian Jackson.
+# Uncomment this to turn on verbose mode.
+export DH_VERBOSE=1
+
SED_COMMAND='s/.*(\([^)]*\)).*/\1/p'
MAJOR := $(shell sed -n $(SED_COMMAND) debian/changelog | head -1 | sed -n 's/\([0-9]*\)\..*/\1/p')
MINOR := $(shell sed -n $(SED_COMMAND) debian/changelog | head -1 | sed -n 's/[0-9]*\.\([0-9\.]*\).*/\1/p')
-package=ivy-c
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+ # Add here commands to configure the package.
+ touch configure-stamp
-build:
- $(checkdir)
- cd src && make all MAJOR=$(MAJOR) MINOR=$(MINOR) TCLINC=$(-I/usr/include/tcl8.3/) TCLLIB=$(-ltcl8.3) CFLAGS="-g -fPIC -D_REENTRANT"
- touch build
+build: build-stamp
+build-stamp: configure-stamp
+ dh_testdir
+ cd src && $(MAKE) all MAJOR=$(MAJOR) MINOR=$(MINOR) TCLINC=$(-I/usr/include/tcl8.3/) TCLLIB=$(-ltcl8.3) CFLAGS="-g -fPIC -D_REENTRANT"
+ touch build-stamp
clean:
- $(checkdir)
- -rm -f build
- -rm -rf debian/tmp debian/*~ debian/copyright `find debian/* -type d ! -name CVS` debian/files* core
- -rm -f debian/*substvars
- cd src && make clean
-
-binary-indep: checkroot build
- $(checkdir)
-# There are no architecture-independent files to be uploaded
-# generated by this package. If there were any they would be
-# made here.
-
-binary-arch: checkroot build
- $(checkdir)
- -rm -rf debian/tmp `find debian/* -type d ! -name CVS`
- install -d debian/tmp
- cd debian/tmp && install -d `cat ../dirs`
-
- cd src && make installlibs PREFIX=`pwd`/../debian/tmp MAJOR=$(MAJOR) MINOR=$(MINOR)
- cd src && make installbins PREFIX=`pwd`/../debian/tmp
- cd src && make installdocs PREFIX=`pwd`/../debian/tmp
-
- -rm debian/tmp/usr/include/list.h # it's yet in utils-c-dev
- -cp src/version.h debian/copyright
- #dh_strip debian/tmp/usr/lib/libivy.so.$(MAJOR).$(MINOR)
- strip debian/tmp/usr/lib/libivy.so.$(MAJOR).$(MINOR)
- #dh_strip debian/tmp/usr/lib/libtclivy.so.$(MAJOR).$(MINOR)
- strip debian/tmp/usr/lib/libtclivy.so.$(MAJOR).$(MINOR)
- #dh_strip debian/tmp/usr/X11R6/lib/libxtivy.so.$(MAJOR).$(MINOR)
- strip debian/tmp/usr/X11R6/lib/libxtivy.so.$(MAJOR).$(MINOR)
-
- dh_link usr/lib/libivy.so.$(MAJOR).$(MINOR) usr/lib/libivy.so.$(MAJOR)
- dh_link usr/lib/libgivy.so.$(MAJOR).$(MINOR) usr/lib/libgivy.so.$(MAJOR)
- dh_link usr/lib/libtclivy.so.$(MAJOR).$(MINOR) usr/lib/libtclivy.so.$(MAJOR)
- dh_link usr/X11R6/lib/libxtivy.so.$(MAJOR).$(MINOR) usr/X11R6/lib/libxtivy.so.$(MAJOR)
- dh_link usr/lib/libivy.so.$(MAJOR).$(MINOR) usr/lib/libivy.so
- dh_link usr/lib/libgivy.so.$(MAJOR).$(MINOR) usr/lib/libgivy.so
- dh_link usr/lib/libtclivy.so.$(MAJOR).$(MINOR) usr/lib/libtclivy.so
- dh_link usr/X11R6/lib/libxtivy.so.$(MAJOR).$(MINOR) usr/X11R6/lib/libxtivy.so
-
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+ cd src && $(MAKE) clean
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+ cd src && $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
+
+binary-indep: build install
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_installexamples
+ dh_install --source=$(CURDIR)/debian/tmp
+# dh_installmenu
+# dh_installdebconf
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+# dh_installinit
+# dh_installcron
+# dh_installinfo
+ dh_installman
+ dh_link
+ dh_strip
+ dh_compress
dh_fixperms
-
- debstd doc/man-ivy-c.html doc/ivy-c-*.html
-
- -rmdir debian/tmp/usr/include
-
- dpkg-gencontrol -p$(package) -isp
- dpkg --build debian/tmp ..
-
-define checkdir
- test -f debian/rules
-endef
-
-# Below here is fairly generic really
-
-binary: binary-indep binary-arch
-
-checkroot:
- $(checkdir)
- test root = "`whoami`"
-
-.PHONY: binary binary-arch binary-indep clean checkroot
+# dh_perl
+# dh_python
+# dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure
diff --git a/debian/substvars b/debian/substvars
new file mode 100644
index 0000000..dc83102
--- /dev/null
+++ b/debian/substvars
@@ -0,0 +1 @@
+shlibs:Depends=libc6 (>= 2.3.2.ds1-21), libglib2.0-0 (>= 2.6.0), libice6, libpcre3 (>= 4.5), libsm6, libx11-6, libxt6