aboutsummaryrefslogtreecommitdiff
path: root/debian/changelog
diff options
context:
space:
mode:
Diffstat (limited to 'debian/changelog')
-rw-r--r--debian/changelog16
1 files changed, 15 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 5e89490..7ff2651 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,16 @@
libivy-java (1.2.6) unstable; urgency=low
+ bugfixes
+ - major cleanup to handle simultaneous connections, e.g., between two
+ busses within the same process ( AsyncAPI test is very stressful )
+ I made an assymetric processing to elect the client that should
+ disconnect based on the socket ports ... might work...
+ - jakarta regexp are not meant to be threadsafe, so for match() and
+ compile() must be enclaused in a synchronized block
+ - now sends back an error message when an incorrect regexp is sent
+ the message is supposed to be readable
+ - IvyWatcher now uses a new buffer for each Datagram received, to prevent an old bug
+
debian package
- the package name goes to libivy-java,
- examples have been added in the documentation and corrected to honor the
@@ -9,6 +20,9 @@ libivy-java (1.2.6) unstable; urgency=low
- the manual has been heavily updated, and C++ has been left out.
new features
+ - Ivy.waitForMsg(regexp,timeout) and Ivy.waitForClient(name,timeout) make
+ the synchronization with other Ivy agents easier. Wait "forever" if
+ timeout is null.
- use Ivy.protectNewLine(true) to ensure encoding and decoding of newline
as 0x1A. As the encoding and decoding cost a little more CPU and is not
yet standardized in the Ivy protocol, use it at your own risk.
@@ -29,7 +43,7 @@ libivy-java (1.2.6) unstable; urgency=low
specified, it takes DEFAULT_PORT
- IvyWatcher's getDomain now sends IvyException for malformed broadcast addresses
- -- Yannick Jestin <jestin@cena.fr> Tue, 27 Aug 2004 16:49:00 +0100
+ -- Yannick Jestin <jestin@cena.fr> Tue, 29 Jul 2004 19:28:00 +0100
ivy-java (1.2.4) unstable; urgency=low