aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog16
-rw-r--r--debian/control6
-rw-r--r--debian/ivy-java4
-rw-r--r--debian/postinst.libivy-java (renamed from debian/postinst.ivy-java)0
-rw-r--r--debian/prerm.libivy-java (renamed from debian/prerm.ivy-java)0
-rwxr-xr-xdebian/rules10
6 files changed, 25 insertions, 11 deletions
diff --git a/debian/changelog b/debian/changelog
index 5e89490..7ff2651 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,16 @@
libivy-java (1.2.6) unstable; urgency=low
+ bugfixes
+ - major cleanup to handle simultaneous connections, e.g., between two
+ busses within the same process ( AsyncAPI test is very stressful )
+ I made an assymetric processing to elect the client that should
+ disconnect based on the socket ports ... might work...
+ - jakarta regexp are not meant to be threadsafe, so for match() and
+ compile() must be enclaused in a synchronized block
+ - now sends back an error message when an incorrect regexp is sent
+ the message is supposed to be readable
+ - IvyWatcher now uses a new buffer for each Datagram received, to prevent an old bug
+
debian package
- the package name goes to libivy-java,
- examples have been added in the documentation and corrected to honor the
@@ -9,6 +20,9 @@ libivy-java (1.2.6) unstable; urgency=low
- the manual has been heavily updated, and C++ has been left out.
new features
+ - Ivy.waitForMsg(regexp,timeout) and Ivy.waitForClient(name,timeout) make
+ the synchronization with other Ivy agents easier. Wait "forever" if
+ timeout is null.
- use Ivy.protectNewLine(true) to ensure encoding and decoding of newline
as 0x1A. As the encoding and decoding cost a little more CPU and is not
yet standardized in the Ivy protocol, use it at your own risk.
@@ -29,7 +43,7 @@ libivy-java (1.2.6) unstable; urgency=low
specified, it takes DEFAULT_PORT
- IvyWatcher's getDomain now sends IvyException for malformed broadcast addresses
- -- Yannick Jestin <jestin@cena.fr> Tue, 27 Aug 2004 16:49:00 +0100
+ -- Yannick Jestin <jestin@cena.fr> Tue, 29 Jul 2004 19:28:00 +0100
ivy-java (1.2.4) unstable; urgency=low
diff --git a/debian/control b/debian/control
index f5b741b..58e2214 100644
--- a/debian/control
+++ b/debian/control
@@ -3,13 +3,13 @@ Section: devel
Priority: optional
Maintainer: Yannick Jestin <jestin@cena.fr>
#Standards-Version: 3.5.2
-Build-Depends: java-compiler, lynx, libregexp-java, lib-gnu.getopt-java, docbook-utils
+Build-Depends: java-compiler, lynx, libregexp-java, (lib-gnu.getopt-java|libgetopt-java), docbook-utils, fastjar
Package: libivy-java
Architecture: all
-Depends: java-virtual-machine, lib-gnu.getopt-java, libregexp-java
+Depends: java-virtual-machine, (lib-gnu.getopt-java|libgetopt-java), libregexp-java
Suggests:
Description: Ivy Software bus for java
- The ivy-java package is a pure-Java implementation of the Ivy software bus
+ The libivy-java package is a pure-Java implementation of the Ivy software bus
messaging scheme. It intends to ease the programming of distributed systems,
by giving the programmer the same kind of API as the programmation of GUIs.
diff --git a/debian/ivy-java b/debian/ivy-java
index b828656..fba84f9 100644
--- a/debian/ivy-java
+++ b/debian/ivy-java
@@ -1,7 +1,7 @@
-Document: ivy-java
+Document: libivy-java
Title: API documentation for ivy-java
Author: Yannick Jestin
-Abstract: API documentation for ivy-java Java package
+Abstract: API documentation for libivy-java Java package
Section: Programming
Format: HTML
diff --git a/debian/postinst.ivy-java b/debian/postinst.libivy-java
index eb4437c..eb4437c 100644
--- a/debian/postinst.ivy-java
+++ b/debian/postinst.libivy-java
diff --git a/debian/prerm.ivy-java b/debian/prerm.libivy-java
index 8927c6d..8927c6d 100644
--- a/debian/prerm.ivy-java
+++ b/debian/prerm.libivy-java
diff --git a/debian/rules b/debian/rules
index 7dedaf5..658980b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,7 +6,7 @@
librules_interface = 1
include debian/librules.mk
-debian/stamp/binary/arch : debian/stamp/binary/ivy-java
+debian/stamp/binary/arch : debian/stamp/binary/libivy-java
debian/stamp/build :
$(MAKE) -C src
@@ -18,8 +18,8 @@ debian/stamp/clean-build:
javarep=$(rootdir)/usr/share/java
mandir=$(rootdir)/usr/share/man/man1
-debian/stamp/binary/ivy-java : package=ivy-java
-debian/stamp/binary/ivy-java : debian/stamp/build
+debian/stamp/binary/libivy-java : package=libivy-java
+debian/stamp/binary/libivy-java : debian/stamp/build
$(prebinary)
$(install_dir) $(bindir)
$(install_dir) $(javarep)
@@ -29,8 +29,8 @@ debian/stamp/binary/ivy-java : debian/stamp/build
$(install_dir) $(docdir)
$(install_dir) $(docbasedir)
$(install_dir) $(mandir)
- ( cd src; jar cvf $(javarep)/ivy.jar fr )
- cp -r src/fr $(javarep)/repository/
+ ( cd src; jar cvfm $(javarep)/ivy.jar ../manifest fr )
+ #cp -r src/fr $(javarep)/repository/
cp tools/jprobe $(bindir)/jprobe
cp -r Changelog $(docdir)
gzip -9 $(docdir)/Changelog