aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorhattenberger2013-02-23 09:42:53 +0000
committerhattenberger2013-02-23 09:42:53 +0000
commitffa561e5237ea7454302a091b7898464e00f5806 (patch)
tree39b0fc3bc6ea5ff895796baeb59e40bd0a0c066b /debian
parente21fa0025a7a310aacd105a5caf945bfc53b0b7c (diff)
downloadivy-ocaml-ffa561e5237ea7454302a091b7898464e00f5806.zip
ivy-ocaml-ffa561e5237ea7454302a091b7898464e00f5806.tar.gz
ivy-ocaml-ffa561e5237ea7454302a091b7898464e00f5806.tar.bz2
ivy-ocaml-ffa561e5237ea7454302a091b7898464e00f5806.tar.xz
use ocamfind to install package
Diffstat (limited to 'debian')
-rw-r--r--debian/control4
-rwxr-xr-xdebian/rules16
2 files changed, 12 insertions, 8 deletions
diff --git a/debian/control b/debian/control
index 4bba10f..48267c3 100644
--- a/debian/control
+++ b/debian/control
@@ -1,8 +1,8 @@
Source: ivy-ocaml
-Section: net
+Section: libs
Priority: optional
Maintainer: Gautier Hattenberger <gautier.hattenberger@enac.fr>
-Build-Depends: debhelper (>= 7.0.50~), dh-ocaml (>= 0.9.0), ocaml-nox, libglib2.0-dev, libpcre3-dev, ivy-c-dev (>=3.11)
+Build-Depends: debhelper (>= 7.0.50~), dh-ocaml (>= 0.9.0), ocaml-nox, ocaml-findlib, libglib2.0-dev, libpcre3-dev, ivy-c-dev (>=3.11)
Standards-Version: 3.9.2
Homepage: http://www2.tls.cena.fr/products/ivy/
Vcs-Svn: http://svn.tls.cena.fr/svn/ivy/ivy-ocaml/trunk
diff --git a/debian/rules b/debian/rules
index 6827cc6..f09e0b2 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,10 +1,11 @@
#!/usr/bin/make -f
# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+include /usr/share/ocaml/ocamlvars.mk
+
+DEB_DESTDIR = $(CURDIR)/debian/ivy-ocaml
+DEB_OCAML_DESTDIR = $(DEB_DESTDIR)$(OCAML_STDLIB_DIR)
+export OCAMLFIND_DESTDIR = $(DEB_OCAML_DESTDIR)
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
@@ -13,5 +14,8 @@
dh $@ --with ocaml
override_dh_auto_install :
- $(MAKE) install DESTDIR=$(CURDIR)/debian/ivy-ocaml
+ mkdir -p $(DEB_OCAML_DESTDIR)
+ mkdir -p $(DEB_OCAML_DESTDIR)/stublibs
+ $(MAKE) DESTDIR=$(DEB_DESTDIR) install
+.PHONY: override_dh_auto_install