summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authoretienne1998-12-14 11:21:59 +0000
committeretienne1998-12-14 11:21:59 +0000
commit9e0974547d19d633c25779529f396fd88ccef097 (patch)
treeff54b4c2358c5e81edb2a65608f880e53ba94c47 /debian/rules
parent866586e32b0f453ec08dbc2fc25e26aeec49871e (diff)
downloadivy-perl-9e0974547d19d633c25779529f396fd88ccef097.zip
ivy-perl-9e0974547d19d633c25779529f396fd88ccef097.tar.gz
ivy-perl-9e0974547d19d633c25779529f396fd88ccef097.tar.bz2
ivy-perl-9e0974547d19d633c25779529f396fd88ccef097.tar.xz
Ajout config Debian
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules50
1 files changed, 50 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..383cbb7
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,50 @@
+#!/usr/bin/make -f
+# Made with the aid of debmake, by Christoph Lameter,
+# based on the sample debian/rules file for GNU hello by Ian Jackson.
+
+package=ivy-perl
+
+build:
+ $(checkdir)
+
+ touch build
+
+clean:
+ $(checkdir)
+ -rm -f build
+ -rm -f `find . -name "*~"`
+ -rm -rf debian/tmp debian/files* core debian/substvars
+
+binary-indep: checkroot build
+ $(checkdir)
+# There are no architecture-independent files to be uploaded
+# generated by this package. If there were any they would be
+# made here.
+
+binary-arch: checkroot build
+ $(checkdir)
+ -rm -rf debian/tmp
+ install -d debian/tmp
+ cd debian/tmp && install -d `cat ../dirs`
+ cp Ivy.pm debian/tmp/usr/local/lib/site_perl
+# Must have debmake installed for this to work. Otherwise please copy
+# /usr/bin/debstd into the debian directory and change debstd to debian/debstd
+ debstd ChangeLog NEWS README TODO
+ dpkg-gencontrol
+ chown -R root.root debian/tmp
+ chmod -R go=rX debian/tmp
+ dpkg --build debian/tmp ..
+
+define checkdir
+ test -f debian/rules
+endef
+
+# Below here is fairly generic really
+
+binary: binary-indep binary-arch
+
+checkroot:
+ $(checkdir)
+ test root = "`whoami`"
+
+.PHONY: binary binary-arch binary-indep clean checkroot